summaryrefslogtreecommitdiffstats
path: root/src/logicalfile/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/logicalfile/CMakeLists.txt')
-rw-r--r--src/logicalfile/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/logicalfile/CMakeLists.txt b/src/logicalfile/CMakeLists.txt
index 7f3c05d..c0d6b25 100644
--- a/src/logicalfile/CMakeLists.txt
+++ b/src/logicalfile/CMakeLists.txt
@@ -19,10 +19,10 @@ add_library(${LIBRARY_NAME} SHARED
${CIM_HEADERS}
)
-#pkg_check_modules(LIBPCI REQUIRED libpci)
+pkg_check_modules(LIBUDEV REQUIRED libudev)
-include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMPI_INCLUDE_DIR} ${LIBPCI_INCLUDE_DIR})
-target_link_libraries(${LIBRARY_NAME} openlmicommon ${KONKRETCMPI_LIBRARIES} ${LIBPCI_LIBRARIES})
+include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMPI_INCLUDE_DIR})
+target_link_libraries(${LIBRARY_NAME} openlmicommon ${KONKRETCMPI_LIBRARIES} ${LIBUDEV_LIBRARIES})
# Create registration file
cim_registration(${PROVIDER_NAME} ${LIBRARY_NAME} ${MOF} share/openlmi-providers)