summaryrefslogtreecommitdiffstats
path: root/src/logicalfile/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/logicalfile/CMakeLists.txt')
-rw-r--r--src/logicalfile/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/logicalfile/CMakeLists.txt b/src/logicalfile/CMakeLists.txt
index c0d6b25..d8c6532 100644
--- a/src/logicalfile/CMakeLists.txt
+++ b/src/logicalfile/CMakeLists.txt
@@ -20,9 +20,16 @@ add_library(${LIBRARY_NAME} SHARED
)
pkg_check_modules(LIBUDEV REQUIRED libudev)
+pkg_check_modules(LIBSELINUX libselinux)
+if(LIBSELINUX_FOUND EQUAL 1)
+ add_definitions(-DLOGICALFILE_SELINUX)
+endif(LIBSELINUX_FOUND EQUAL 1)
include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMPI_INCLUDE_DIR})
-target_link_libraries(${LIBRARY_NAME} openlmicommon ${KONKRETCMPI_LIBRARIES} ${LIBUDEV_LIBRARIES})
+target_link_libraries(${LIBRARY_NAME} openlmicommon
+ ${KONKRETCMPI_LIBRARIES}
+ ${LIBUDEV_LIBRARIES}
+ ${LIBSELINUX_LIBRARIES})
# Create registration file
cim_registration(${PROVIDER_NAME} ${LIBRARY_NAME} ${MOF} share/openlmi-providers)