summaryrefslogtreecommitdiffstats
path: root/src/hardware/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/hardware/CMakeLists.txt')
-rw-r--r--src/hardware/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/hardware/CMakeLists.txt b/src/hardware/CMakeLists.txt
new file mode 100644
index 0000000..27e8df2
--- /dev/null
+++ b/src/hardware/CMakeLists.txt
@@ -0,0 +1,29 @@
+
+set(PROVIDER_NAME Hardware)
+set(LIBRARY_NAME cmpiLMI_${PROVIDER_NAME})
+set(MOF LMI_Hardware.mof)
+
+#set(provider_SRCS
+# util/serviceutil.c
+#)
+
+konkretcmpi_generate(${MOF}
+ CIM_PROVIDERS
+ CIM_HEADERS
+)
+
+add_library(${LIBRARY_NAME} SHARED
+ ${provider_SRCS}
+ ${CIM_PROVIDERS}
+ ${CIM_HEADERS}
+)
+
+pkg_check_modules(LIBPCI REQUIRED libpci)
+
+include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMPI_INCLUDE_DIR} ${LIBPCI_INCLUDE_DIR})
+target_link_libraries(${LIBRARY_NAME} openlmicommon ${KONKRETCMPI_LIBRARIES} ${LIBPCI_LIBRARIES})
+
+# Create registration file
+cim_registration(${PROVIDER_NAME} ${LIBRARY_NAME} ${MOF} share/openlmi-providers)
+
+install(TARGETS ${LIBRARY_NAME} DESTINATION lib${LIB_SUFFIX}/cmpi)