summaryrefslogtreecommitdiffstats
path: root/src/fan/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/fan/CMakeLists.txt')
-rw-r--r--src/fan/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/fan/CMakeLists.txt b/src/fan/CMakeLists.txt
index a5324f7..0028997 100644
--- a/src/fan/CMakeLists.txt
+++ b/src/fan/CMakeLists.txt
@@ -26,6 +26,8 @@ target_link_libraries(${LIBRARY_NAME} openlmicommon ${KONKRETCMPI_LIBRARIES} sen
# Create registration file
cim_registration(${PROVIDER_NAME} ${LIBRARY_NAME} ${MOF} share/openlmi-providers)
+set(TARGET_MOF "${CMAKE_BINARY_DIR}/mof/90_LMI_Fan_Profile.mof")
+profile_mof_generate("90_LMI_Fan_Profile.mof.skel" "${TARGET_MOF}" "${CIM_CLASSES}")
install(TARGETS ${LIBRARY_NAME} DESTINATION lib${LIB_SUFFIX}/cmpi/)
-
+install(FILES ${TARGET_MOF} DESTINATION share/openlmi-providers/)