summaryrefslogtreecommitdiffstats
path: root/src/fan/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/fan/CMakeLists.txt')
-rw-r--r--src/fan/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/fan/CMakeLists.txt b/src/fan/CMakeLists.txt
index 0028997..7c17f50 100644
--- a/src/fan/CMakeLists.txt
+++ b/src/fan/CMakeLists.txt
@@ -2,6 +2,7 @@
set(PROVIDER_NAME Fan)
set(LIBRARY_NAME cmpiLMI_${PROVIDER_NAME})
set(MOF 60_LMI_Fan.mof)
+set(FAN_SCRIPT cmpiLMI_${PROVIDER_NAME}-cimprovagt)
set(provider_SRCS
fan.c
@@ -31,3 +32,4 @@ profile_mof_generate("90_LMI_Fan_Profile.mof.skel" "${TARGET_MOF}" "${CIM_CLASSE
install(TARGETS ${LIBRARY_NAME} DESTINATION lib${LIB_SUFFIX}/cmpi/)
install(FILES ${TARGET_MOF} DESTINATION share/openlmi-providers/)
+install(PROGRAMS ${FAN_SCRIPT} DESTINATION libexec/pegasus)