summaryrefslogtreecommitdiffstats
path: root/src/account/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/account/CMakeLists.txt')
-rw-r--r--src/account/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/account/CMakeLists.txt b/src/account/CMakeLists.txt
index 61075a1..d839565 100644
--- a/src/account/CMakeLists.txt
+++ b/src/account/CMakeLists.txt
@@ -30,6 +30,16 @@ add_library(${LIBRARY_NAME} SHARED
${CIM_HEADERS}
)
+set(CIM_PROVIDERS_CLASSES "")
+foreach(CIM_CLASS ${CIM_CLASSES})
+ if(NOT ${CIM_CLASS} MATCHES "Indication")
+ set(CIM_PROVIDERS_CLASSES ${CIM_PROVIDERS_CLASSES} ${CIM_CLASS})
+ endif(NOT ${CIM_CLASS} MATCHES "Indication")
+endforeach(CIM_CLASS ${CIM_CLASSES})
+
+set(TARGET_MOF "${CMAKE_BINARY_DIR}/mof/90_LMI_Account_Profile.mof")
+profile_mof_generate("90_LMI_Account_Profile.mof.skel" "${TARGET_MOF}" "${CIM_PROVIDERS_CLASSES}")
+
# Require GLib-2.0 and libuser
pkg_check_modules(GLIB REQUIRED glib-2.0)
pkg_check_modules(LIBUSER REQUIRED libuser)
@@ -43,3 +53,4 @@ cim_registration(${PROVIDER_NAME} ${LIBRARY_NAME} ${MOF} share/openlmi-providers
install(TARGETS ${LIBRARY_NAME} DESTINATION lib${LIB_SUFFIX}/cmpi/)
install(PROGRAMS ${ACCOUNT_SCRIPT} DESTINATION libexec/pegasus)
+install(FILES ${TARGET_MOF} DESTINATION share/openlmi/providers/)