summaryrefslogtreecommitdiffstats
path: root/src/account/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/account/CMakeLists.txt')
-rw-r--r--src/account/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/account/CMakeLists.txt b/src/account/CMakeLists.txt
new file mode 100644
index 0000000..35fd843
--- /dev/null
+++ b/src/account/CMakeLists.txt
@@ -0,0 +1,38 @@
+
+set(PROVIDER_NAME Account)
+set(LIBRARY_NAME cmpiCura_${PROVIDER_NAME})
+set(MOF Cura_Account.mof)
+
+set(provider_SRCS
+ aux_lu.c
+)
+
+konkretcmpi_generate(${MOF}
+ CIM_PROVIDERS
+ CIM_HEADERS
+)
+
+add_library(${LIBRARY_NAME} SHARED
+ ${provider_SRCS}
+ ${CIM_PROVIDERS}
+ ${CIM_HEADERS}
+)
+
+# Require GLib-2.0 and libuser
+pkg_check_modules(GLIB REQUIRED glib-2.0)
+pkg_check_modules(LIBUSER REQUIRED libuser)
+
+include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMPI_INCLUDE_DIR} ${GLIB_INCLUDE_DIRS})
+
+target_link_libraries(${LIBRARY_NAME} curacommon ${KONKRETCMPI_LIBRARIES} ${GLIB_LIBRARIES})
+
+
+include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMPI_INCLUDE_DIR} ${LIBUSER_INCLUDE_DIRS})
+
+target_link_libraries(${LIBRARY_NAME} curacommon ${KONKRETCMPI_LIBRARIES} ${LIBUSER_LIBRARIES})
+
+# Create registration file
+cim_registration(${PROVIDER_NAME} ${LIBRARY_NAME} ${MOF})
+
+install(TARGETS ${LIBRARY_NAME} DESTINATION lib${LIB_SUFFIX}/cmpi/)
+