summaryrefslogtreecommitdiffstats
path: root/openlmi-providers.spec
diff options
context:
space:
mode:
Diffstat (limited to 'openlmi-providers.spec')
-rw-r--r--openlmi-providers.spec64
1 files changed, 64 insertions, 0 deletions
diff --git a/openlmi-providers.spec b/openlmi-providers.spec
index fd1b833..813bdd5 100644
--- a/openlmi-providers.spec
+++ b/openlmi-providers.spec
@@ -22,6 +22,7 @@
%global with_locale 1
%global with_indsender 1
%global with_jobmanager 1
+%global with_sssd 1
%if 0%{?rhel} == 6
%global with_journald 0
@@ -33,6 +34,7 @@
%global with_locale 0
%global with_indsender 0
%global with_jobmanager 0
+%global with_sssd 0
%global interop root/PG_InterOp
%endif
@@ -74,6 +76,7 @@ Obsoletes: cura-providers < 0.0.10-1
%global pcp_version %{providers_version_release}
%global journald_version %{providers_version_release}
%global realmd_version %{providers_version_release}
+%global sssd_version %{providers_version_release}
# Storage and networking providers are built out of tree
# We will require a minimum and maximum version of them
@@ -143,6 +146,9 @@ BuildRequires: dbus-1-devel
%else
BuildRequires: dbus-devel
%endif
+%if 0%{?with_sssd}
+BuildRequires: libsss_simpleifp-devel
+%endif
# sblim-sfcb or tog-pegasus
# (required to be present during install/uninstall for registration)
Requires: cim-server
@@ -541,6 +547,23 @@ BuildArch: noarch
This package contains the documents for OpenLMI Journald provider.
%endif
+%if 0%{?with_sssd}
+%package -n openlmi-sssd
+Summary: CIM provider for SSSD
+Requires: %{name}%{?_isa} = %{providers_version_release}
+
+%description -n openlmi-sssd
+The openlmi-sssd package contains CMPI providers for SSSD service.
+
+%package -n openlmi-sssd-doc
+Summary: CIM SSSD provider documentation
+Group: Documentation
+BuildArch: noarch
+
+%description -n openlmi-sssd-doc
+This package contains the documents for OpenLMI SSSD provider.
+%endif
+
%if 0%{?with_devassistant}
%package -n openlmi-devassistant
Summary: OpenLMI provider templates for Developer Assistant
@@ -621,6 +644,9 @@ pushd %{_target_platform}
%if ! 0%{with_jobmanager}
-DWITH-JOBMANAGER=OFF \
%endif
+%if ! 0%{with_sssd}
+ -DWITH-SSSD=OFF \
+%endif
%{source_dir}
popd
@@ -714,6 +740,9 @@ for provider in \
%if 0%{?with_locale}
locale \
%endif
+%if 0%{?with_sssd}
+ sssd \
+%endif
software; do
install -m 755 -d $RPM_BUILD_ROOT/%{_docdir}/%{name}/${provider}/admin_guide
@@ -960,6 +989,19 @@ cp -pr tools/openlmitheme/* $RPM_BUILD_ROOT/%{python_sitelib}/sphinx/themes/open
%{_docdir}/%{name}/journald/
%endif
+%if 0%{with_sssd}
+%files -n openlmi-sssd
+%doc README COPYING
+%{_libdir}/cmpi/libcmpiLMI_SSSD.so
+%{_datadir}/%{name}/60_LMI_SSSD.mof
+%{_datadir}/%{name}/60_LMI_SSSD.reg
+%{_datadir}/%{name}/90_LMI_SSSD_Profile.mof
+%attr(755, root, root) %{_libexecdir}/pegasus/cmpiLMI_SSSD-cimprovagt
+
+%files -n openlmi-sssd-doc
+%{_docdir}/%{name}/sssd/
+%endif
+
%if 0%{with_devassistant}
%files -n openlmi-devassistant
%dir %{_datadir}/devassistant/files/crt/python/openlmi/
@@ -1262,6 +1304,17 @@ if [ "$1" -ge 1 ]; then
fi >> %logfile 2>&1
%endif
+%if 0%{with_sssd}
+%post -n openlmi-sssd
+if [ "$1" -ge 1 ]; then
+ %{_bindir}/openlmi-mof-register -v %{providers_version} register \
+ %{_datadir}/%{name}/60_LMI_SSSD.mof \
+ %{_datadir}/%{name}/60_LMI_SSSD.reg || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/interop -c tog-pegasus register \
+ %{_datadir}/%{name}/90_LMI_SSSD_Profile.mof || :;
+fi >> %logfile 2>&1
+%endif
+
%if 0%{with_fan}
%preun -n openlmi-fan
# Deregister only if not upgrading
@@ -1389,6 +1442,17 @@ if [ "$1" -eq 0 ]; then
fi >> %logfile 2>&1
%endif
+%if 0%{with_sssd}
+%preun -n openlmi-sssd
+if [ "$1" -eq 0 ]; then
+ %{_bindir}/openlmi-mof-register -v %{providers_version} unregister \
+ %{_datadir}/%{name}/60_LMI_SSSD.mof \
+ %{_datadir}/%{name}/60_LMI_SSSD.reg || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/interop -c tog-pegasus unregister \
+ %{_datadir}/%{name}/90_LMI_SSSD_Profile.mof || :;
+fi >> %logfile 2>&1
+%endif
+
%changelog
* Thu Jun 26 2014 Radek Novacek <rnovacek@redhat.com> 0.4.2-16
- Add BR: json-glib-devel for jobmanager