summaryrefslogtreecommitdiffstats
path: root/openlmi-providers.spec
diff options
context:
space:
mode:
Diffstat (limited to 'openlmi-providers.spec')
-rw-r--r--openlmi-providers.spec61
1 files changed, 61 insertions, 0 deletions
diff --git a/openlmi-providers.spec b/openlmi-providers.spec
index dc975d5..fc37aa8 100644
--- a/openlmi-providers.spec
+++ b/openlmi-providers.spec
@@ -19,6 +19,7 @@
%global with_pcp 1
%global with_realmd 1
%global with_fan 1
+%global with_sssd 1
%if 0%{?rhel} == 6
%global with_journald 0
@@ -27,6 +28,7 @@
%global with_pcp 0
%global with_realmd 0
%global with_fan 0
+%global with_sssd 0
%global interop root/PG_InterOp
%endif
@@ -68,6 +70,7 @@ Obsoletes: cura-providers < 0.0.10-1
%global pcp_version %{providers_version_release}
%global journald_version %{providers_version_release}
%global realmd_version %{providers_version_release}
+%global sssd_version %{providers_version_release}
# Storage and networking providers are built out of tree
# We will require a minimum and maximum version of them
@@ -137,6 +140,9 @@ BuildRequires: dbus-1-devel
%else
BuildRequires: dbus-devel
%endif
+%if 0%{?with_sssd}
+BuildRequires: libsss_simpleifp-devel
+%endif
# sblim-sfcb or tog-pegasus
# (required to be present during install/uninstall for registration)
Requires: cim-server
@@ -497,6 +503,23 @@ BuildArch: noarch
This package contains the documents for OpenLMI Journald provider.
%endif
+%if 0%{?with_sssd}
+%package -n openlmi-sssd
+Summary: CIM provider for SSSD
+Requires: %{name}%{?_isa} = %{providers_version_release}
+
+%description -n openlmi-sssd
+The openlmi-sssd package contains CMPI providers for SSSD service.
+
+%package -n openlmi-sssd-doc
+Summary: CIM SSSD provider documentation
+Group: Documentation
+BuildArch: noarch
+
+%description -n openlmi-sssd-doc
+This package contains the documents for OpenLMI SSSD provider.
+%endif
+
%if 0%{?with_devassistant}
%package -n openlmi-devassistant
Summary: OpenLMI provider templates for Developer Assistant
@@ -551,6 +574,9 @@ pushd %{_target_platform}
%if ! 0%{with_fan}
-DWITH-FAN=OFF \
%endif
+%if ! 0%{with_fan}
+ -DWITH-SSSD=OFF \
+%endif
%{source_dir}
popd
@@ -861,6 +887,19 @@ cp -pr tools/openlmitheme/* $RPM_BUILD_ROOT/%{python_sitelib}/sphinx/themes/open
%{_docdir}/%{name}/journald/
%endif
+%if 0%{with_sssd}
+%files -n openlmi-sssd
+%doc README COPYING
+%{_libdir}/cmpi/libcmpiLMI_SSSD.so
+%{_datadir}/%{name}/60_LMI_SSSD.mof
+%{_datadir}/%{name}/60_LMI_SSSD.reg
+%{_datadir}/%{name}/90_LMI_SSSD_Profile.mof
+%attr(755, root, root) %{_libexecdir}/pegasus/cmpiLMI_SSSD-cimprovagt
+
+%files -n openlmi-sssd-doc
+%{_docdir}/%{name}/sssd/
+%endif
+
%if 0%{with_devassistant}
%files -n openlmi-devassistant
%dir %{_datadir}/devassistant/files/crt/python/openlmi/
@@ -1116,6 +1155,17 @@ if [ "$1" -ge 1 ]; then
fi >> %logfile 2>&1
%endif
+%if 0%{with_sssd}
+%post -n openlmi-sssd
+if [ "$1" -ge 1 ]; then
+ %{_bindir}/openlmi-mof-register -v %{providers_version} register \
+ %{_datadir}/%{name}/60_LMI_SSSD.mof \
+ %{_datadir}/%{name}/60_LMI_SSSD.reg || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/interop -c tog-pegasus register \
+ %{_datadir}/%{name}/90_LMI_SSSD_Profile.mof || :;
+fi >> %logfile 2>&1
+%endif
+
%if 0%{with_fan}
%preun -n openlmi-fan
# Deregister only if not upgrading
@@ -1232,6 +1282,17 @@ if [ "$1" -eq 0 ]; then
fi >> %logfile 2>&1
%endif
+%if 0%{with_sssd}
+%preun -n openlmi-sssd
+if [ "$1" -eq 0 ]; then
+ %{_bindir}/openlmi-mof-register -v %{providers_version} unregister \
+ %{_datadir}/%{name}/60_LMI_SSSD.mof \
+ %{_datadir}/%{name}/60_LMI_SSSD.reg || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/interop -c tog-pegasus unregister \
+ %{_datadir}/%{name}/90_LMI_SSSD_Profile.mof || :;
+fi >> %logfile 2>&1
+%endif
+
%changelog
* Mon May 26 2014 Tomas Bzatek <tbzatek@redhat.com> 0.4.2-11
- Include journald indication filters