summaryrefslogtreecommitdiffstats
path: root/openlmi-providers.spec
diff options
context:
space:
mode:
Diffstat (limited to 'openlmi-providers.spec')
-rw-r--r--openlmi-providers.spec10
1 files changed, 10 insertions, 0 deletions
diff --git a/openlmi-providers.spec b/openlmi-providers.spec
index b1fe5b5..8f3870a 100644
--- a/openlmi-providers.spec
+++ b/openlmi-providers.spec
@@ -278,6 +278,7 @@ mkdir -p $RPM_BUILD_ROOT/%{_localstatedir}/lib/%{name}
%{_libdir}/cmpi/libcmpiLMI_Fan.so
%{_datadir}/%{name}/60_LMI_Fan.mof
%{_datadir}/%{name}/60_LMI_Fan.reg
+%{_datadir}/%{name}/90_LMI_Fan_Profile.mof
%files -n openlmi-powermanagement
%doc README COPYING
@@ -428,6 +429,9 @@ if [ "$1" -gt 1 ]; then
%{_datadir}/%{name}/60_LMI_Fan.mof \
%{_datadir}/%{name}/60_LMI_Fan.reg \
> /dev/null 2>&1 || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/interop unregister \
+ %{_datadir}/%{name}/90_LMI_Fan_Profile.mof \
+ > /dev/null 2>&1 || :;
fi
%pre -n openlmi-powermanagement
@@ -525,6 +529,9 @@ if [ "$1" -ge 1 ]; then
%{_datadir}/%{name}/60_LMI_Fan.mof \
%{_datadir}/%{name}/60_LMI_Fan.reg \
> /dev/null 2>&1 || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/interop register \
+ %{_datadir}/%{name}/90_LMI_Fan_Profile.mof \
+ > /dev/null 2>&1 || :;
fi
%post -n openlmi-powermanagement
@@ -622,6 +629,9 @@ if [ "$1" -eq 0 ]; then
%{_datadir}/%{name}/60_LMI_Fan.mof \
%{_datadir}/%{name}/60_LMI_Fan.reg \
> /dev/null 2>&1 || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/interop unregister \
+ %{_datadir}/%{name}/90_LMI_Fan_Profile.mof \
+ > /dev/null 2>&1 || :;
fi
%preun -n openlmi-powermanagement