summaryrefslogtreecommitdiffstats
path: root/openlmi-providers.spec
diff options
context:
space:
mode:
Diffstat (limited to 'openlmi-providers.spec')
-rw-r--r--openlmi-providers.spec11
1 files changed, 11 insertions, 0 deletions
diff --git a/openlmi-providers.spec b/openlmi-providers.spec
index 9d754e7..01f6c48 100644
--- a/openlmi-providers.spec
+++ b/openlmi-providers.spec
@@ -293,6 +293,8 @@ mkdir -p $RPM_BUILD_ROOT/%{_localstatedir}/lib/%{name}
%{_libdir}/cmpi/libcmpiLMI_Service.so
%{_datadir}/%{name}/60_LMI_Service.mof
%{_datadir}/%{name}/60_LMI_Service.reg
+%{_datadir}/%{name}/90_LMI_Service_Profile.mof
+%attr(755, root, root) %{_libexecdir}/pegasus/cmpiLMI_Service-cimprovagt
%files -n openlmi-account
%doc README COPYING
@@ -429,6 +431,9 @@ if [ "$1" -gt 1 ]; then
%{_datadir}/%{name}/60_LMI_Service.mof \
%{_datadir}/%{name}/60_LMI_Service.reg \
> /dev/null 2>&1 || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/interop unregister \
+ %{_datadir}/%{name}/90_LMI_Service_Profile.mof \
+ > /dev/null 2>&1 || :;
fi
%pre -n openlmi-account
@@ -530,6 +535,9 @@ if [ "$1" -ge 1 ]; then
%{_datadir}/%{name}/60_LMI_Service.mof \
%{_datadir}/%{name}/60_LMI_Service.reg \
> /dev/null 2>&1 || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/interop register \
+ %{_datadir}/%{name}/90_LMI_Service_Profile.mof \
+ > /dev/null 2>&1 || :;
fi
%post -n openlmi-account
@@ -629,6 +637,9 @@ if [ "$1" -eq 0 ]; then
%{_datadir}/%{name}/60_LMI_Service.mof \
%{_datadir}/%{name}/60_LMI_Service.reg \
> /dev/null 2>&1 || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/interop unregister \
+ %{_datadir}/%{name}/90_LMI_Service_Profile.mof \
+ > /dev/null 2>&1 || :;
fi
%preun -n openlmi-account