summaryrefslogtreecommitdiffstats
path: root/openlmi-providers.spec
diff options
context:
space:
mode:
Diffstat (limited to 'openlmi-providers.spec')
-rw-r--r--openlmi-providers.spec10
1 files changed, 10 insertions, 0 deletions
diff --git a/openlmi-providers.spec b/openlmi-providers.spec
index 9f79668..4e879d5 100644
--- a/openlmi-providers.spec
+++ b/openlmi-providers.spec
@@ -450,6 +450,9 @@ if [ "$1" -gt 1 ]; then
%{_datadir}/%{name}/60_LMI_Account.mof \
%{_datadir}/%{name}/60_LMI_Account.reg \
> /dev/null 2>&1 || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/interop unregister \
+ %{_datadir}/%{name}/90_LMI_Account_Profile.mof \
+ > /dev/null 2>&1 || :;
fi
%pre -n openlmi-software
@@ -538,6 +541,9 @@ if [ "$1" -ge 1 ]; then
%{_datadir}/%{name}/60_LMI_Account.mof \
%{_datadir}/%{name}/60_LMI_Account.reg \
> /dev/null 2>&1 || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/interop register \
+ %{_datadir}/%{name}/90_LMI_Account_Profile.mof \
+ > /dev/null 2>&1 || :;
fi
%post -n openlmi-software
@@ -625,6 +631,9 @@ if [ "$1" -eq 0 ]; then
%{_datadir}/%{name}/60_LMI_Account.mof \
%{_datadir}/%{name}/60_LMI_Account.reg \
> /dev/null 2>&1 || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/interop unregister \
+ %{_datadir}/%{name}/90_LMI_Account_Profile.mof \
+ > /dev/null 2>&1 || :;
fi
%preun -n openlmi-software
@@ -684,6 +693,7 @@ fi
%changelog
* Thu Jul 25 2013 Jan Synáček <jsynacek@redhat.com> - 0.0.25-9
- Add logicalfile profile registration
+- Correctly register account profiles
* Thu Jul 25 2013 Radek Novacek <rnovacek@redhat.com> - 0.0.25-8
- Add version to mof/reg registration