summaryrefslogtreecommitdiffstats
path: root/src/software/setup.py
diff options
context:
space:
mode:
authorMichal Minar <miminar@redhat.com>2013-02-04 12:37:58 +0100
committerMichal Minar <miminar@redhat.com>2013-02-04 14:51:03 +0100
commit775290a2c13b801c84fefdc4538fe110c4df6c24 (patch)
tree04427c4859b874ed4346a042f3d097ba51fa50d7 /src/software/setup.py
parent861a85d3b8e7ed6eaa68edc6d03f1192d46272e1 (diff)
downloadopenlmi-providers-775290a2c13b801c84fefdc4538fe110c4df6c24.tar.gz
openlmi-providers-775290a2c13b801c84fefdc4538fe110c4df6c24.tar.xz
openlmi-providers-775290a2c13b801c84fefdc4538fe110c4df6c24.zip
rewritten for safe execution of transactions
Made separate process openlmi.software.yumdb.process.YumWorker for calls to yum API. Its client openlmi.software.yumdb.YumDB communicates with it via synchronnous queues - uplink and downlink. Resolves: #63 in openlmi trac -- yum API not useable, while changing thread_id) Resolves: #33 in openlmi trac -- Install/remove package Common functionality of providers moved under openlmi.software.core subpackage to make them easily accessible from other providers without cyclic dependencies. Improved logging with cmpi_logging module. openlmi.software.cimom_entry module now is the only module loadable by cmpi-bindings. It sets up providers and maps them by their name. New subpackages: openlmi.software.core openlmi.software.yumdb
Diffstat (limited to 'src/software/setup.py')
-rw-r--r--src/software/setup.py8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/software/setup.py b/src/software/setup.py
index 25eb001..a044ac0 100644
--- a/src/software/setup.py
+++ b/src/software/setup.py
@@ -5,9 +5,13 @@ setup(
author='Michal Minar',
author_email='miminar@redhat.com',
url='https://fedorahosted.org/openlmi/',
- version='0.5',
+ version='0.6',
namespace_packages=['openlmi'],
- packages=['openlmi.software', 'openlmi.software.util'],
+ packages=[
+ 'openlmi.software',
+ 'openlmi.software.core',
+ 'openlmi.software.util',
+ 'openlmi.software.yumdb'],
install_requires=['openlmi'],
license="LGPLv2+",
classifiers=[