summaryrefslogtreecommitdiffstats
path: root/src/software/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Minar <miminar@redhat.com>2013-07-26 13:07:32 +0200
committerMichal Minar <miminar@redhat.com>2013-07-26 15:12:38 +0200
commite119dc8c4c3fa2a3798d123356449b10e3a0ab66 (patch)
tree0d8dcbe0d9dd106ad673d62fae0d685c98d41f56 /src/software/CMakeLists.txt
parent64fd6cfeabb250a8ea162de7b3babb4b0febefb5 (diff)
downloadopenlmi-providers-e119dc8c4c3fa2a3798d123356449b10e3a0ab66.tar.gz
openlmi-providers-e119dc8c4c3fa2a3798d123356449b10e3a0ab66.tar.xz
openlmi-providers-e119dc8c4c3fa2a3798d123356449b10e3a0ab66.zip
software: added profile registration mof skeleton
created single instance of PG_ProviderProfileCapabilities with the following DMTF subprofiles: * Job Control * Software Identity * Software Update skeleton is parsed with cmake, which sets the VERSION and writes it to mof/ directory
Diffstat (limited to 'src/software/CMakeLists.txt')
-rw-r--r--src/software/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/software/CMakeLists.txt b/src/software/CMakeLists.txt
new file mode 100644
index 0000000..7b2c670
--- /dev/null
+++ b/src/software/CMakeLists.txt
@@ -0,0 +1,9 @@
+SET(TARGET_MOF "${CMAKE_BINARY_DIR}/mof/90_LMI_Software_Profiler.mof")
+SET(SKEL_MOF "90_LMI_Software_Profile.mof.skel")
+SET(INSTANCE_SKEL "")
+
+file(READ "${SKEL_MOF}" INSTANCE_SKEL)
+file(WRITE "${TARGET_MOF}" "")
+string(REPLACE "\@VERSION\@" ${OPENLMI_VERSION} INSTANCE "${INSTANCE_SKEL}")
+file(APPEND "${TARGET_MOF}" "${INSTANCE}")
+message(STATUS "Generated profile mof ${OUT_MOF}")