summaryrefslogtreecommitdiffstats
path: root/src/service/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Minar <miminar@redhat.com>2013-04-18 16:03:19 +0200
committerMichal Minar <miminar@redhat.com>2013-04-22 18:59:04 +0200
commitcb3913a5177f998acb503691fb1908f82c7f890b (patch)
tree819f60359938871c0e728432623ea4151f607d8f /src/service/CMakeLists.txt
parent6c3ca07f99bb8eeb0ef8aae5d72682d2f860c2a1 (diff)
downloadopenlmi-providers-cb3913a5177f998acb503691fb1908f82c7f890b.tar.gz
openlmi-providers-cb3913a5177f998acb503691fb1908f82c7f890b.tar.xz
openlmi-providers-cb3913a5177f998acb503691fb1908f82c7f890b.zip
renamed mof files according to LMI convention
Mof files prefixed with digits ensuring their correct order of parsing upon their installation. This avoids problems with sfcbmof compiler, which can not handle dependent classes being parsed before their antecedents. Convention is specified in mof/README. Removed inclusion of LMI_Qualifiers in LMI_Jobs. LMI_Qualifiers should be registered in cimom instead of included in dependent mof files. This allows it to be used by any other providers simultaneously. Modified references to mof files in cmake build files.
Diffstat (limited to 'src/service/CMakeLists.txt')
-rw-r--r--src/service/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/service/CMakeLists.txt b/src/service/CMakeLists.txt
index c0f236f..34d766e 100644
--- a/src/service/CMakeLists.txt
+++ b/src/service/CMakeLists.txt
@@ -1,7 +1,7 @@
set(PROVIDER_NAME Service)
set(LIBRARY_NAME cmpiLMI_${PROVIDER_NAME})
-set(MOF LMI_Service.mof)
+set(MOF 60_LMI_Service.mof)
set(provider_SRCS
util/serviceutil.c