summaryrefslogtreecommitdiffstats
path: root/src/power/CMakeLists.txt
diff options
context:
space:
mode:
authorRadek Novacek <rnovacek@redhat.com>2012-07-23 12:41:11 +0200
committerRadek Novacek <rnovacek@redhat.com>2012-07-23 12:41:11 +0200
commit7bc4421f26954c2acd817c690cbbde03a4391878 (patch)
tree85bd87c085bab9fe8bf8c62ee8e41f95d283e977 /src/power/CMakeLists.txt
parent8061ba1c48f6b8448a458d1919cd6520e2e4a658 (diff)
downloadopenlmi-providers-7bc4421f26954c2acd817c690cbbde03a4391878.tar.gz
openlmi-providers-7bc4421f26954c2acd817c690cbbde03a4391878.tar.xz
openlmi-providers-7bc4421f26954c2acd817c690cbbde03a4391878.zip
Move all providers to src/ directory
Diffstat (limited to 'src/power/CMakeLists.txt')
-rw-r--r--src/power/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/power/CMakeLists.txt b/src/power/CMakeLists.txt
new file mode 100644
index 0000000..72087b7
--- /dev/null
+++ b/src/power/CMakeLists.txt
@@ -0,0 +1,19 @@
+
+cmake_minimum_required (VERSION 2.6)
+
+set(CMAKE_C_FLAGS "-std=c99 -Wall -pedantic -g")
+
+add_subdirectory(src)
+
+if(CMAKE_SIZEOF_VOID_P EQUAL 4)
+ set(LIB_SUFFIX "")
+else(CMAKE_SIZEOF_VOID_P EQUAL 4)
+ SET(LIB_SUFFIX 64)
+endif(CMAKE_SIZEOF_VOID_P EQUAL 4)
+
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/src/Linux_PowerManagement.registration DESTINATION share/sblim-cmpi-power/)
+install(FILES Linux_PowerManagement.mof DESTINATION share/sblim-cmpi-power/)
+install(FILES provider-register.sh DESTINATION share/sblim-cmpi-power/)
+
+add_custom_target(register
+ ${CMAKE_CURRENT_SOURCE_DIR}/provider-register.sh -m ${CMAKE_CURRENT_SOURCE_DIR}/Linux_PowerManagement.mof -r ${CMAKE_CURRENT_BINARY_DIR}/src/Linux_PowerManagement.registration)