summaryrefslogtreecommitdiffstats
path: root/src/power/CMakeLists.txt
diff options
context:
space:
mode:
authorRadek Novacek <rnovacek@redhat.com>2012-07-27 09:35:03 +0200
committerRadek Novacek <rnovacek@redhat.com>2012-07-27 09:35:03 +0200
commit171113535983029ab395341c8f8f3c92f320ea1a (patch)
tree2e7f2f064d29804666465166c114aa7f7845e134 /src/power/CMakeLists.txt
parent99b6e54a64d962d226679ca290117f114eaf8245 (diff)
downloadopenlmi-providers-171113535983029ab395341c8f8f3c92f320ea1a.tar.gz
openlmi-providers-171113535983029ab395341c8f8f3c92f320ea1a.tar.xz
openlmi-providers-171113535983029ab395341c8f8f3c92f320ea1a.zip
Unify logging through all providers
Needs to be ported to sfcb/pegasus standard logging, using stderr for now.
Diffstat (limited to 'src/power/CMakeLists.txt')
-rw-r--r--src/power/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/power/CMakeLists.txt b/src/power/CMakeLists.txt
index 4c06beb..606c1f3 100644
--- a/src/power/CMakeLists.txt
+++ b/src/power/CMakeLists.txt
@@ -5,8 +5,6 @@ set(MOF Linux_PowerManagement.mof)
set(provider_SRCS
power.c
- trace.c
- globals.c
)
konkretcmpi_generate(${MOF}
@@ -22,7 +20,7 @@ add_library(${LIBRARY_NAME} SHARED
include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMPI_INCLUDE_DIR} ${GLIB_INCLUDE_DIRS})
-target_link_libraries(${LIBRARY_NAME} ${KONKRETCMPI_LIBRARIES} ${GLIB_LIBRARIES})
+target_link_libraries(${LIBRARY_NAME} curacommon ${KONKRETCMPI_LIBRARIES} ${GLIB_LIBRARIES})
# Check if we have upower and link it
pkg_check_modules(UPOWER upower-glib)