summaryrefslogtreecommitdiffstats
path: root/src/hardware/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Schiffer <pschiffe@redhat.com>2013-03-06 13:16:25 +0100
committerPeter Schiffer <pschiffe@redhat.com>2013-03-06 13:16:25 +0100
commit7a0b251bcd55a26679bb99480f02948105947d05 (patch)
tree5b836c12b12ff900d1a069d44306b09189cb70c7 /src/hardware/CMakeLists.txt
parent72f6010fc7dd68ea2ecd9431f906d077a7c20181 (diff)
downloadopenlmi-providers-7a0b251bcd55a26679bb99480f02948105947d05.tar.gz
openlmi-providers-7a0b251bcd55a26679bb99480f02948105947d05.tar.xz
openlmi-providers-7a0b251bcd55a26679bb99480f02948105947d05.zip
Created LMI_ProcessorProvider providing basic information about CPU. Main source
of information is dmidecode program, with additional information from lscpu program and /proc/cpuinfo file. If no output from dmidecode program is available, fallback with only lscpu and /proc/cpuinfo is used.
Diffstat (limited to 'src/hardware/CMakeLists.txt')
-rw-r--r--src/hardware/CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/src/hardware/CMakeLists.txt b/src/hardware/CMakeLists.txt
index 27e8df2..ebf79fb 100644
--- a/src/hardware/CMakeLists.txt
+++ b/src/hardware/CMakeLists.txt
@@ -1,11 +1,14 @@
-
set(PROVIDER_NAME Hardware)
set(LIBRARY_NAME cmpiLMI_${PROVIDER_NAME})
set(MOF LMI_Hardware.mof)
-#set(provider_SRCS
-# util/serviceutil.c
-#)
+set(provider_SRCS
+ utils.c
+ dmidecode.c
+ lscpu.c
+ cpuinfo.c
+ LMI_ProcessorProvider.c
+)
konkretcmpi_generate(${MOF}
CIM_PROVIDERS