summaryrefslogtreecommitdiffstats
path: root/src/hardware/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Schiffer <pschiffe@redhat.com>2013-07-29 13:27:48 +0200
committerPeter Schiffer <pschiffe@redhat.com>2013-07-29 13:27:48 +0200
commit6bd39a5e4f44bf757767dd8dbc3b906b0396f1ec (patch)
tree404616da4ede384279abcc4fabeaca67b7db85d2 /src/hardware/CMakeLists.txt
parentcc31492633d833c5d5ae06a62a8303f5210c387a (diff)
downloadopenlmi-providers-6bd39a5e4f44bf757767dd8dbc3b906b0396f1ec.tar.gz
openlmi-providers-6bd39a5e4f44bf757767dd8dbc3b906b0396f1ec.tar.xz
openlmi-providers-6bd39a5e4f44bf757767dd8dbc3b906b0396f1ec.zip
Hardware: Added profile registration
Diffstat (limited to 'src/hardware/CMakeLists.txt')
-rw-r--r--src/hardware/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/hardware/CMakeLists.txt b/src/hardware/CMakeLists.txt
index 728c3d8..8089a08 100644
--- a/src/hardware/CMakeLists.txt
+++ b/src/hardware/CMakeLists.txt
@@ -31,5 +31,12 @@ target_link_libraries(${LIBRARY_NAME} openlmicommon ${KONKRETCMPI_LIBRARIES} ${L
# Create registration file
cim_registration(${PROVIDER_NAME} ${LIBRARY_NAME} ${MOF} share/openlmi-providers)
+set(TARGET_MOF "${CMAKE_BINARY_DIR}/mof/90_LMI_${PROVIDER_NAME}_Profile.mof")
+profile_mof_generate("90_LMI_${PROVIDER_NAME}_Profile.mof.skel" "${TARGET_MOF}" "${CIM_CLASSES}")
+set(TARGET_MOF_DMTF "${CMAKE_BINARY_DIR}/mof/90_LMI_${PROVIDER_NAME}_Profile_DMTF.mof")
+configure_file("90_LMI_${PROVIDER_NAME}_Profile_DMTF.mof" "${TARGET_MOF_DMTF}" COPYONLY)
+
install(TARGETS ${LIBRARY_NAME} DESTINATION lib${LIB_SUFFIX}/cmpi)
install(PROGRAMS ${CIMPROVAGT_SCRIPT} DESTINATION libexec/pegasus)
+install(FILES ${TARGET_MOF} DESTINATION share/openlmi-providers/)
+install(FILES ${TARGET_MOF_DMTF} DESTINATION share/openlmi-providers/)