summaryrefslogtreecommitdiffstats
path: root/src/account/CMakeLists.txt
diff options
context:
space:
mode:
authorRoman Rakus <rrakus@redhat.com>2013-06-26 16:39:57 +0200
committerRoman Rakus <rrakus@redhat.com>2013-07-01 11:32:25 +0200
commit17155ddc8f2d7168a8f6f6fa24439342758d3125 (patch)
treeb917be9030dd0d64be5d701b20d4d410da3350ce /src/account/CMakeLists.txt
parent9382852767bcd560fa14e9cdbbbc8764fdf4dd91 (diff)
downloadopenlmi-providers-17155ddc8f2d7168a8f6f6fa24439342758d3125.tar.gz
openlmi-providers-17155ddc8f2d7168a8f6f6fa24439342758d3125.tar.xz
openlmi-providers-17155ddc8f2d7168a8f6f6fa24439342758d3125.zip
Account: Indications for creation and deletion
Signed-off-by: Roman Rakus <rrakus@redhat.com>
Diffstat (limited to 'src/account/CMakeLists.txt')
-rw-r--r--src/account/CMakeLists.txt13
1 files changed, 5 insertions, 8 deletions
diff --git a/src/account/CMakeLists.txt b/src/account/CMakeLists.txt
index 38ecd02..a8f8553 100644
--- a/src/account/CMakeLists.txt
+++ b/src/account/CMakeLists.txt
@@ -7,6 +7,7 @@ set(ACCOUNT_SCRIPT cmpiLMI_${PROVIDER_NAME}-cimprovagt)
set(provider_SRCS
aux_lu.c
account_globals.c
+ indication_common.c
)
if (NOT DEFINED CRYPT_ALGS)
@@ -15,7 +16,7 @@ if (NOT DEFINED CRYPT_ALGS)
endif (NOT DEFINED CRYPT_ALGS)
message ("Using crypto algorithms: ${CRYPT_ALGS}")
-add_definitions(-DCRYPT_ALGS=${CRYPT_ALGS})
+add_definitions(-DCRYPT_ALGS=${CRYPT_ALGS} -DINOTIFY_THREAD_SAFE)
konkretcmpi_generate(${MOF}
CIM_PROVIDERS
@@ -31,15 +32,11 @@ add_library(${LIBRARY_NAME} SHARED
# Require GLib-2.0 and libuser
pkg_check_modules(GLIB REQUIRED glib-2.0)
pkg_check_modules(LIBUSER REQUIRED libuser)
+pkg_check_modules(IM REQUIRED openlmiindmanager)
-include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMPI_INCLUDE_DIR} ${GLIB_INCLUDE_DIRS})
+include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMPI_INCLUDE_DIR} ${GLIB_INCLUDE_DIRS} ${LIBUSER_INCLUDE_DIRS} ${IM_INCLUDE_DIRS})
-target_link_libraries(${LIBRARY_NAME} openlmicommon ${KONKRETCMPI_LIBRARIES} ${GLIB_LIBRARIES})
-
-
-include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMPI_INCLUDE_DIR} ${LIBUSER_INCLUDE_DIRS})
-
-target_link_libraries(${LIBRARY_NAME} openlmicommon ${KONKRETCMPI_LIBRARIES} ${LIBUSER_LIBRARIES})
+target_link_libraries(${LIBRARY_NAME} openlmicommon ${KONKRETCMPI_LIBRARIES} ${GLIB_LIBRARIES} ${LIBUSER_LIBRARIES} ${IM_LIBRARIES})
# Create registration file
cim_registration(${PROVIDER_NAME} ${LIBRARY_NAME} ${MOF} share/openlmi-providers)