summaryrefslogtreecommitdiffstats
path: root/src/account/CMakeLists.txt
diff options
context:
space:
mode:
authorRoman Rakus <rrakus@redhat.com>2012-11-07 13:51:28 +0100
committerRoman Rakus <rrakus@redhat.com>2012-11-07 13:51:28 +0100
commitfcba47aa00263ffd0e6372d7de4ce20b04132559 (patch)
tree98cbb8dbfad898a7bf3bf6fe45a5a08ce5b62708 /src/account/CMakeLists.txt
parent0bd973c335dd56a198c05cc2fe2f37c99ac1d961 (diff)
downloadopenlmi-providers-fcba47aa00263ffd0e6372d7de4ce20b04132559.tar.gz
openlmi-providers-fcba47aa00263ffd0e6372d7de4ce20b04132559.tar.xz
openlmi-providers-fcba47aa00263ffd0e6372d7de4ce20b04132559.zip
Account: Compiletime definition of supported encrypt algorithms0.0.13
Signed-off-by: Roman Rakus <rrakus@redhat.com>
Diffstat (limited to 'src/account/CMakeLists.txt')
-rw-r--r--src/account/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/account/CMakeLists.txt b/src/account/CMakeLists.txt
index 7aa517e..2c1d817 100644
--- a/src/account/CMakeLists.txt
+++ b/src/account/CMakeLists.txt
@@ -5,8 +5,17 @@ set(MOF LMI_Account.mof)
set(provider_SRCS
aux_lu.c
+ account_globals.c
)
+if (NOT DEFINED CRYPT_ALGS)
+ message ("Setting default crypto algorithms")
+ set (CRYPT_ALGS "\"DES\"")
+endif (NOT DEFINED CRYPT_ALGS)
+
+message ("Using crypto algorithms: ${CRYPT_ALGS}")
+add_definitions(-DCRYPT_ALGS=${CRYPT_ALGS})
+
konkretcmpi_generate(${MOF}
CIM_PROVIDERS
CIM_HEADERS