summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Safranek <jsafrane@redhat.com>2013-11-01 12:32:29 +0100
committerJan Safranek <jsafrane@redhat.com>2013-11-01 12:32:29 +0100
commitdd73461cec68d4ee72d54067c560451db70ddce8 (patch)
tree87ae9e5622f9829d346e84d0ec7d9875786d6c07 /src/CMakeLists.txt
parent8e4f595d6b1861732d39564e9e1b8305d7987beb (diff)
downloadopenlmi-providers-dd73461cec68d4ee72d54067c560451db70ddce8.tar.gz
openlmi-providers-dd73461cec68d4ee72d54067c560451db70ddce8.tar.xz
openlmi-providers-dd73461cec68d4ee72d54067c560451db70ddce8.zip
Work around Pegasus destroying threads _after_ unloading provider dynamic library.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e2317ed..47d1ed3 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -4,7 +4,7 @@ add_library(openlmicommon SHARED
openlmi.c
)
-target_link_libraries(openlmicommon ${GLIB_LIBRARIES})
+target_link_libraries(openlmicommon ${GLIB_LIBRARIES} dl)
set(OPENLMICOMMON_VERSION_MAJOR 0)
set(OPENLMICOMMON_VERSION_MINOR 0)