summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRadek Novacek <rnovacek@redhat.com>2014-04-10 14:30:11 +0200
committerRadek Novacek <rnovacek@redhat.com>2014-04-10 14:31:08 +0200
commitb65667c9324eba14e3da7d4cb85711bac7afcd4d (patch)
tree501a0e5376a5e1ff85ee71079fb17e51b3d1f01c /src/CMakeLists.txt
parentbbf83307946d07c7189ba7bfe90b56797c11ef39 (diff)
downloadopenlmi-providers-b65667c9324eba14e3da7d4cb85711bac7afcd4d.tar.gz
openlmi-providers-b65667c9324eba14e3da7d4cb85711bac7afcd4d.tar.xz
openlmi-providers-b65667c9324eba14e3da7d4cb85711bac7afcd4d.zip
fix for older versions of cmake
Older versions of cmake needs to have absolute path in the destination paremeter of configure_file command.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4227ccb..ed81b0e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -16,7 +16,7 @@ set_target_properties(openlmicommon PROPERTIES SOVERSION ${OPENLMICOMMON_VERSION
install(TARGETS openlmicommon DESTINATION lib${LIB_SUFFIX})
install(FILES openlmi.h DESTINATION include/openlmi)
-configure_file(openlmi.pc.in openlmi.pc @ONLY)
+configure_file(openlmi.pc.in ${CMAKE_CURRENT_BINARY_DIR}/openlmi.pc @ONLY)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/openlmi.pc DESTINATION lib${LIB_SUFFIX}/pkgconfig)
install(FILES openlmi.conf DESTINATION ${SYSCONF_INSTALL_DIR}/openlmi)