summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorVitezslav Crhonek <vcrhonek@redhat.com>2014-04-17 10:47:10 +0200
committerVitezslav Crhonek <vcrhonek@redhat.com>2014-04-17 10:47:10 +0200
commit344131a6142cc3b52d8eec10f07ac21aefd4d5a0 (patch)
tree90da363ceef6c6a499cd75b8aff8545f42ab9de7 /src/CMakeLists.txt
parent27f4dfc7029293ec8e16a92f627f48bbc129c846 (diff)
downloadopenlmi-providers-344131a6142cc3b52d8eec10f07ac21aefd4d5a0.tar.gz
openlmi-providers-344131a6142cc3b52d8eec10f07ac21aefd4d5a0.tar.xz
openlmi-providers-344131a6142cc3b52d8eec10f07ac21aefd4d5a0.zip
Service-legacy (non d-bus):
- Add support for building service-legacy provider into cmake files (OFF by default) - Add service-legacy mof file (no indications, builds with older cmake) - Fix service enumeration (use chkconfig)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ed81b0e..abca02d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -32,6 +32,10 @@ if (WITH-SERVICE)
add_subdirectory(service-dbus)
endif (WITH-SERVICE)
+if (WITH-SERVICE-LEGACY)
+ add_subdirectory(service)
+endif (WITH-SERVICE-LEGACY)
+
if (WITH-ACCOUNT)
add_subdirectory(account)
endif (WITH-ACCOUNT)