summaryrefslogtreecommitdiffstats
path: root/openlmi-providers.spec
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2013-11-25 11:13:40 -0500
committerStephen Gallagher <sgallagh@redhat.com>2013-12-03 09:20:22 -0500
commitef66fc25bb2049246caa1c1ff0a8b3436701d594 (patch)
tree388203e346721e1a6a799ce879565455a937db2d /openlmi-providers.spec
parentda34dc409c8f96d05433f0b3b4574e7a639ee141 (diff)
downloadopenlmi-providers-ef66fc25bb2049246caa1c1ff0a8b3436701d594.tar.gz
openlmi-providers-ef66fc25bb2049246caa1c1ff0a8b3436701d594.tar.xz
openlmi-providers-ef66fc25bb2049246caa1c1ff0a8b3436701d594.zip
Define OpenLMI 1.0.0
Set strict version dependencies for the meta-package
Diffstat (limited to 'openlmi-providers.spec')
-rw-r--r--openlmi-providers.spec61
1 files changed, 53 insertions, 8 deletions
diff --git a/openlmi-providers.spec b/openlmi-providers.spec
index aa2225f..1a1ccc1 100644
--- a/openlmi-providers.spec
+++ b/openlmi-providers.spec
@@ -4,7 +4,7 @@
Name: openlmi-providers
Version: 0.4.1
-Release: 3%{?dist}
+Release: 4%{?dist}
Summary: Set of basic CIM providers
License: LGPLv2+
@@ -15,6 +15,29 @@ Source0: http://fedorahosted.org/released/openlmi-providers/%{name}-%{ver
Provides: cura-providers = %{version}-%{release}
Obsoletes: cura-providers < 0.0.10-1
+# == Provider versions ==
+
+# Providers built from this package need to be strictly
+# matched, so that they are always upgraded together.
+%global hw_version %{version}-%{release}
+%global sw_version %{version}-%{release}
+%global pwmgmt_version %{version}-%{release}
+%global acct_version %{version}-%{release}
+%global svc_version %{version}-%{release}
+%global pcp_version %{version}-%{release}
+%global journald_version %{version}-%{release}
+%global realmd_version %{version}-%{release}
+
+# Storage and networking providers are built out of tree
+# We will require a minimum and maximum version of them
+# to ensure that they are tested together.
+%global storage_min_version 0.7.0
+%global storage_max_version 0.8
+
+%global nw_min_version 0.2.1
+%global nw_max_version 0.3
+
+
BuildRequires: cmake
BuildRequires: konkretcmpi-devel >= %{required_konkret_ver}
BuildRequires: sblim-cmpi-devel
@@ -273,17 +296,35 @@ into strings on demand.
%package -n openlmi
Summary: OpenLMI managed system software components
+Version: 1.0.0
Requires: %{name} = %{version}-%{release}
BuildArch: noarch
Requires: tog-pegasus
# List of "safe" providers
-Requires: openlmi-storage
-Requires: openlmi-networking
-Requires: openlmi-hardware
-Requires: openlmi-software
-Requires: openlmi-powermanagement
-Requires: openlmi-account
-Requires: openlmi-service
+Requires: openlmi-hardware = %{hw_version}
+Requires: openlmi-software = %{sw_version}
+Requires: openlmi-powermanagement = %{pwmgmt_version}
+Requires: openlmi-account = %{acct_version}
+Requires: openlmi-service = %{svc_version}
+
+# Mandatory, out-of-tree providers
+Requires: openlmi-storage >= %{storage_min_version}
+Conflicts: openlmi-storage >= %{storage_max_version}
+Requires: openlmi-networking >= %{nw_min_version}
+Conflicts: openlmi-networking >= %{nw_max_version}
+
+# Optional Providers
+# This ensures that only the appropriate version is installed but does
+# not install it by default. If these packages are installed, this will
+# guarantee that they are updated to the appropriate version on upgrade.
+Conflicts: openlmi-pcp > %{pcp_version}
+Conflicts: openlmi-pcp < %{pcp_version}
+
+Conflicts: openlmi-journald > %{journald_version}
+Conflicts: openlmi-journald < %{journald_version}
+
+Conflicts: openlmi-realmd > %{realmd_version}
+Conflicts: openlmi-realmd < %{realmd_version}
%description -n openlmi
OpenLMI provides a common infrastructure for the management of Linux systems.
@@ -890,6 +931,10 @@ if [ "$1" -eq 0 ]; then
fi >> %logfile 2>&1
%changelog
+* Mon Nov 25 2013 Stephen Gallagher <sgallagh@redhat.com> 0.4.1-4
+- Define OpenLMI 1.0.0
+- Set strict version dependencies for the meta-package
+
* Wed Nov 06 2013 Tomas Bzatek <tbzatek@redhat.com> 0.4.1-3
- Added explicit dependency on new libuser release