summaryrefslogtreecommitdiffstats
path: root/openlmi-providers.spec
diff options
context:
space:
mode:
authorJan Synacek <jsynacek@redhat.com>2013-07-26 10:33:03 +0200
committerJan Synacek <jsynacek@redhat.com>2013-07-26 12:00:39 +0200
commite5c8ae992dfaff13a1d29624464cce935373c0fb (patch)
tree8f57de618c559f00e78d099867879c0a1b280743 /openlmi-providers.spec
parent1105d99b1ff631935140809047b9eb9684c712e0 (diff)
downloadopenlmi-providers-e5c8ae992dfaff13a1d29624464cce935373c0fb.tar.gz
openlmi-providers-e5c8ae992dfaff13a1d29624464cce935373c0fb.tar.xz
openlmi-providers-e5c8ae992dfaff13a1d29624464cce935373c0fb.zip
realmd: add profile registration and class versioning in mof
Diffstat (limited to 'openlmi-providers.spec')
-rw-r--r--openlmi-providers.spec9
1 files changed, 9 insertions, 0 deletions
diff --git a/openlmi-providers.spec b/openlmi-providers.spec
index 91149b1..b1fe5b5 100644
--- a/openlmi-providers.spec
+++ b/openlmi-providers.spec
@@ -495,6 +495,9 @@ if [ "$1" -gt 1 ]; then
%{_datadir}/%{name}/60_LMI_Realmd.mof \
%{_datadir}/%{name}/60_LMI_Realmd.reg \
> /dev/null 2>&1 || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/interop unregister \
+ %{_datadir}/%{name}/90_LMI_Realmd_Profile.mof \
+ > /dev/null 2>&1 || :;
fi
@@ -590,6 +593,9 @@ if [ "$1" -gt 1 ]; then
%{_datadir}/%{name}/60_LMI_Realmd.mof \
%{_datadir}/%{name}/60_LMI_Realmd.reg \
> /dev/null 2>&1 || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/interop register \
+ %{_datadir}/%{name}/90_LMI_Realmd_Profile.mof \
+ > /dev/null 2>&1 || :;
fi
%post -n openlmi-hardware
@@ -683,6 +689,9 @@ if [ "$1" -gt 1 ]; then
%{_datadir}/%{name}/60_LMI_Realmd.mof \
%{_datadir}/%{name}/60_LMI_Realmd.reg \
> /dev/null 2>&1 || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/interop unregister \
+ %{_datadir}/%{name}/90_LMI_Realmd_Profile.mof \
+ > /dev/null 2>&1 || :;
fi
%preun -n openlmi-hardware