summaryrefslogtreecommitdiffstats
path: root/openlmi-providers.spec
diff options
context:
space:
mode:
authorMichal Minar <miminar@redhat.com>2013-07-04 12:24:06 +0200
committerMichal Minar <miminar@redhat.com>2013-07-10 07:45:43 +0200
commitf7660edd0f0b1068038f8d4e92830c9e986a72c9 (patch)
treea5ff36ea4ada789ccb9c27ff68db4a9cab5ba105 /openlmi-providers.spec
parent5fa1202caa877ab87e195403cdbd33a8643c8e80 (diff)
downloadopenlmi-providers-f7660edd0f0b1068038f8d4e92830c9e986a72c9.tar.gz
openlmi-providers-f7660edd0f0b1068038f8d4e92830c9e986a72c9.tar.xz
openlmi-providers-f7660edd0f0b1068038f8d4e92830c9e986a72c9.zip
added profile registration class
Each OpenLMI profile should define static instance of LMI_RegisteredProfile in one of its mof files. This instance should use CIM_RegisteredProfile::RegisteredVersion to say, which version of DMTF/SMASH profile it implements. And Major/Minor versions and RevisionNumber for any API/implementation changes.
Diffstat (limited to 'openlmi-providers.spec')
-rw-r--r--openlmi-providers.spec30
1 files changed, 29 insertions, 1 deletions
diff --git a/openlmi-providers.spec b/openlmi-providers.spec
index 8ba0330..9fb1fb1 100644
--- a/openlmi-providers.spec
+++ b/openlmi-providers.spec
@@ -1,6 +1,6 @@
Name: openlmi-providers
Version: 0.0.25
-Release: 3%{?dist}
+Release: 4%{?dist}
Summary: Set of basic CIM providers
License: LGPLv2+
@@ -222,6 +222,7 @@ cp mof/LMI_Software.reg $RPM_BUILD_ROOT/%{_datadir}/%{name}/
%dir %{_datadir}/%{name}
%{_datadir}/%{name}/05_LMI_Qualifiers.mof
%{_datadir}/%{name}/30_LMI_Jobs.mof
+%{_datadir}/%{name}/30_LMI_ProfileRegistration.mof
%{_libdir}/libopenlmicommon.so.*
%attr(755, root, root) %{_bindir}/openlmi-mof-register
%attr(755, root, root) %{_libexecdir}/openlmi-register-pegasus
@@ -317,6 +318,14 @@ if [ "$1" -gt 1 ]; then
%{_datadir}/%{name}/05_LMI_Qualifiers.mof \
%{_datadir}/%{name}/30_LMI_Jobs.mof \
> /dev/null 2>&1 || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/interop \
+ -c sfcbd unregister \
+ %{_datadir}/%{name}/30_LMI_ProfileRegistration.mof \
+ > /dev/null 2>&1 || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/PG_InterOp \
+ -c tog-pegasus unregister \
+ %{_datadir}/%{name}/30_LMI_ProfileRegistration.mof \
+ > /dev/null 2>&1 || :;
fi
%post
@@ -326,6 +335,14 @@ if [ "$1" -ge 1 ]; then
%{_datadir}/%{name}/05_LMI_Qualifiers.mof \
%{_datadir}/%{name}/30_LMI_Jobs.mof \
> /dev/null 2>&1 || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/interop \
+ -c sfcbd register \
+ %{_datadir}/%{name}/30_LMI_ProfileRegistration.mof \
+ > /dev/null 2>&1 || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/PG_InterOp \
+ -c tog-pegasus register \
+ %{_datadir}/%{name}/30_LMI_ProfileRegistration.mof \
+ > /dev/null 2>&1 || :;
fi
%preun
@@ -335,6 +352,14 @@ if [ "$1" -eq 0 ]; then
%{_datadir}/%{name}/05_LMI_Qualifiers.mof \
%{_datadir}/%{name}/30_LMI_Jobs.mof \
> /dev/null 2>&1 || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/interop \
+ -c sfcbd unregister \
+ %{_datadir}/%{name}/30_LMI_ProfileRegistration.mof \
+ > /dev/null 2>&1 || :;
+ %{_bindir}/openlmi-mof-register --just-mofs -n root/PG_InterOp \
+ -c tog-pegasus unregister \
+ %{_datadir}/%{name}/30_LMI_ProfileRegistration.mof \
+ > /dev/null 2>&1 || :;
fi
%postun -p /sbin/ldconfig
@@ -568,6 +593,9 @@ if [ "$1" -gt 1 ]; then
fi
%changelog
+* Thu Jul 04 2013 Michal Minar <miminar@redhat.com> 0.0.25-4
+- Added profile registration mof file.
+
* Wed Jul 03 2013 Michal Minar <miminar@redhat.com> 0.0.25-3
- Renamed openlmi python namespace to lmi.