summaryrefslogtreecommitdiffstats
path: root/openlmi-providers.spec
diff options
context:
space:
mode:
authorPeter Schiffer <pschiffe@redhat.com>2013-06-27 16:42:08 +0200
committerPeter Schiffer <pschiffe@redhat.com>2013-06-27 16:42:08 +0200
commitc5d2e0c4da395fd169f1a1b1b31eafc112426660 (patch)
treeaf776cab6d8925447737dbb7fdbb6f910f94dbfe /openlmi-providers.spec
parente7cee30c0f2ff6a63e78c48e6b56755c84a96788 (diff)
downloadopenlmi-providers-c5d2e0c4da395fd169f1a1b1b31eafc112426660.tar.gz
openlmi-providers-c5d2e0c4da395fd169f1a1b1b31eafc112426660.tar.xz
openlmi-providers-c5d2e0c4da395fd169f1a1b1b31eafc112426660.zip
Updated .spec file for hardware sub-package
Changelog: * Added requires for openlmi-hardware sub-package * Added missing %pre, %post and %preun sections for openlmi-hardware sub-package
Diffstat (limited to 'openlmi-providers.spec')
-rw-r--r--openlmi-providers.spec27
1 files changed, 27 insertions, 0 deletions
diff --git a/openlmi-providers.spec b/openlmi-providers.spec
index e0ca2a3..5a8c21c 100644
--- a/openlmi-providers.spec
+++ b/openlmi-providers.spec
@@ -104,6 +104,9 @@ Summary: CIM provider for hardware on system
Requires: %{name}%{?_isa} = %{version}-%{release}
# For Linux_ComputerSystem
Requires: sblim-cmpi-base
+# For Hardware information
+Requires: dmidecode
+Requires: util-linux
%description -n openlmi-hardware
%{summary}.
@@ -397,6 +400,14 @@ if [ "$1" -gt 1 ]; then
> /dev/null 2>&1 || :;
fi
+%pre -n openlmi-hardware
+if [ "$1" -gt 1 ]; then
+ %{_bindir}/openlmi-mof-register unregister \
+ %{_datadir}/%{name}/60_LMI_Hardware.mof \
+ %{_datadir}/%{name}/60_LMI_Hardware.reg \
+ > /dev/null 2>&1 || :;
+fi
+
%post -n openlmi-fan
# Register Schema and Provider
if [ "$1" -ge 1 ]; then
@@ -464,6 +475,14 @@ if [ "$1" -gt 1 ]; then
> /dev/null 2>&1 || :;
fi
+%post -n openlmi-hardware
+if [ "$1" -gt 1 ]; then
+ %{_bindir}/openlmi-mof-register register \
+ %{_datadir}/%{name}/60_LMI_Hardware.mof \
+ %{_datadir}/%{name}/60_LMI_Hardware.reg \
+ > /dev/null 2>&1 || :;
+fi
+
%preun -n openlmi-fan
# Deregister only if not upgrading
if [ "$1" -eq 0 ]; then
@@ -531,6 +550,14 @@ if [ "$1" -gt 1 ]; then
> /dev/null 2>&1 || :;
fi
+%preun -n openlmi-hardware
+if [ "$1" -gt 1 ]; then
+ %{_bindir}/openlmi-mof-register unregister \
+ %{_datadir}/%{name}/60_LMI_Hardware.mof \
+ %{_datadir}/%{name}/60_LMI_Hardware.reg \
+ > /dev/null 2>&1 || :;
+fi
+
%changelog
* Mon Jun 03 2013 Roman Rakus <rrakus@redhat.com> - 0.0.25-1
- Release 0.0.25