summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRadek Novacek <rnovacek@redhat.com>2013-09-18 08:00:08 +0200
committerRadek Novacek <rnovacek@redhat.com>2013-09-18 08:00:38 +0200
commite4d72c3b72f2f363ec556c5f0ec6d94bd4f038ed (patch)
treed50d5e7ba4d238725a48c97659a7c40e1131729a /CMakeLists.txt
parent87ac9c8b710ff016ac6db4311503a5b699b91c41 (diff)
downloadopenlmi-providers-e4d72c3b72f2f363ec556c5f0ec6d94bd4f038ed.tar.gz
openlmi-providers-e4d72c3b72f2f363ec556c5f0ec6d94bd4f038ed.tar.xz
openlmi-providers-e4d72c3b72f2f363ec556c5f0ec6d94bd4f038ed.zip
Introduce toplevel openlmi config file
Toplevel openlmi configuration file (/etc/openlmi/openlmi.conf) now contains common configuration options for all providers. Configuration for each provider could be overriden in provider-specific config (/etc/openlmi/$provider/$provider.conf). This patch also modify config file handling in python providers to include this config file. There is also support for C providers (in libopenlmicommon) for reading these config files and providing default configuration options.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8bb4dd2..d3184e9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,10 @@ else(CMAKE_SIZEOF_VOID_P EQUAL 4)
SET(LIB_SUFFIX 64)
endif(CMAKE_SIZEOF_VOID_P EQUAL 4)
+if(NOT SYSCONF_INSTALL_DIR)
+ set(SYSCONF_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/etc)
+endif(NOT SYSCONF_INSTALL_DIR)
+
option(WITH-FAN "Build fan provider" ON)
option(WITH-POWER "Build power provider" ON)
option(WITH-SERVICE "Build service provider" ON)
@@ -40,6 +44,8 @@ find_package(PkgConfig)
find_package(CMPI REQUIRED)
find_package(KonkretCMPI REQUIRED)
+pkg_check_modules(GLIB REQUIRED glib-2.0)
+
add_subdirectory(src)
add_subdirectory(mof)
add_subdirectory(tools)