summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Minar <miminar@redhat.com>2013-07-26 13:07:32 +0200
committerMichal Minar <miminar@redhat.com>2013-07-26 15:12:38 +0200
commite119dc8c4c3fa2a3798d123356449b10e3a0ab66 (patch)
tree0d8dcbe0d9dd106ad673d62fae0d685c98d41f56 /CMakeLists.txt
parent64fd6cfeabb250a8ea162de7b3babb4b0febefb5 (diff)
downloadopenlmi-providers-e119dc8c4c3fa2a3798d123356449b10e3a0ab66.tar.gz
openlmi-providers-e119dc8c4c3fa2a3798d123356449b10e3a0ab66.tar.xz
openlmi-providers-e119dc8c4c3fa2a3798d123356449b10e3a0ab66.zip
software: added profile registration mof skeleton
created single instance of PG_ProviderProfileCapabilities with the following DMTF subprofiles: * Job Control * Software Identity * Software Update skeleton is parsed with cmake, which sets the VERSION and writes it to mof/ directory
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ed4fd27..cb4ea5e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,6 +27,7 @@ option(WITH-HARDWARE "Build hardware provider" ON)
option(WITH-LOGICALFILE "Build logical file provider" ON)
option(WITH-REALMD "Build RealmD provider" ON)
option(WITH-INDMANAGER "Build indication manager" ON)
+option(WITH-SOFTWARE "Build software provider" ON)
# Set path to custom cmake modules
set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules ${CMAKE_MODULE_PATH})