summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRadek Novacek <rnovacek@redhat.com>2013-04-08 11:09:53 +0200
committerRadek Novacek <rnovacek@redhat.com>2013-04-17 12:31:25 +0200
commitc14bd833b7b1b3b1283d116a87b6f293377f129b (patch)
tree09e297a582294bfe137ef4e2fc0927bbdd33784c /CMakeLists.txt
parent1b8ac75de453d41f5cc78695cb7f5cec476cf674 (diff)
downloadopenlmi-providers-c14bd833b7b1b3b1283d116a87b6f293377f129b.tar.gz
openlmi-providers-c14bd833b7b1b3b1283d116a87b6f293377f129b.tar.xz
openlmi-providers-c14bd833b7b1b3b1283d116a87b6f293377f129b.zip
Support for using libopenlmicommon by external providers
* add FindOpenLMI.cmake module * add pkgconfig for OpenLMI * add openlmi.c/h with exported functions * add symlink with major version to openlmicommon library Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=948948
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 230ed26..b42debc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,3 +39,4 @@ install(PROGRAMS openlmi-register-pegasus DESTINATION libexec)
install(FILES cmake/modules/OpenLMIMacros.cmake DESTINATION share/cmake/Modules)
install(FILES cmake/modules/FindCMPI.cmake DESTINATION share/cmake/Modules)
install(FILES cmake/modules/FindKonkretCMPI.cmake DESTINATION share/cmake/Modules)
+install(FILES cmake/modules/FindOpenLMI.cmake DESTINATION share/cmake/Modules)