summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRadek Novacek <rnovacek@redhat.com>2012-10-24 09:45:25 +0200
committerRadek Novacek <rnovacek@redhat.com>2012-10-24 09:45:25 +0200
commit371066acd6e0c37e9558c2143069a758b9f26070 (patch)
treee8645bb8f85450d7b9607ffb9bbac1cae9751841 /CMakeLists.txt
parentb6917503f020b96c29c26940d50bb3f46b8edcb2 (diff)
downloadopenlmi-providers-371066acd6e0c37e9558c2143069a758b9f26070.tar.gz
openlmi-providers-371066acd6e0c37e9558c2143069a758b9f26070.tar.xz
openlmi-providers-371066acd6e0c37e9558c2143069a758b9f26070.zip
Honor user $CFLAGS
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 63bf93a..e44fd76 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,7 +3,7 @@ cmake_minimum_required(VERSION 2.6)
# Set flags and definitions
add_definitions(-D_XOPEN_SOURCE=500 -D_GNU_SOURCE)
-set(CMAKE_C_FLAGS "-std=c99 -Wall -pedantic -g -Wextra -Wno-unused-parameter -Wformat -Wparentheses -Wl,--no-undefined")
+set(CMAKE_C_FLAGS "-std=c99 -Wall -pedantic -g -Wextra -Wno-unused-parameter -Wformat -Wparentheses -Wl,--no-undefined ${CMAKE_C_FLAGS}")
# Set LIB_SUFFIX to 64 on 64bit architectures
if(CMAKE_SIZEOF_VOID_P EQUAL 4)