summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTomas Bzatek <tbzatek@redhat.com>2013-08-23 14:44:02 +0200
committerTomas Bzatek <tbzatek@redhat.com>2013-10-15 15:23:49 +0200
commit144dcfc5a924ecba7f615064156f6a40247c39b2 (patch)
treee877b70f634e42603b5755213f6b2bac99bdd4fa /CMakeLists.txt
parent7584e2fb80a74b7e4db3b653937a2c6ee64a7400 (diff)
downloadopenlmi-providers-144dcfc5a924ecba7f615064156f6a40247c39b2.tar.gz
openlmi-providers-144dcfc5a924ecba7f615064156f6a40247c39b2.tar.xz
openlmi-providers-144dcfc5a924ecba7f615064156f6a40247c39b2.zip
journald: Basic provider implementation
This is a fully functional basic implementation of the provider. Maximum number of enumerated instances is limited, see the code. TODO list: https://fedorahosted.org/openlmi/ticket/142
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 546742e..351e66d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,6 +32,7 @@ option(WITH-LOGICALFILE "Build logical file provider" ON)
option(WITH-REALMD "Build RealmD provider" ON)
option(WITH-INDMANAGER "Build indication manager" ON)
option(WITH-SOFTWARE "Build software provider" ON)
+option(WITH-JOURNALD "Build journald provider" ON)
# Set path to custom cmake modules
set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules ${CMAKE_MODULE_PATH})