summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRadek Novacek <rnovacek@redhat.com>2013-07-25 11:49:39 +0200
committerRadek Novacek <rnovacek@redhat.com>2013-07-25 11:49:39 +0200
commit5e4d1ea25b66830c428f00f6a9db3b650dcd1696 (patch)
treee976f0103e2b58fd2bb9420d6846b052d0d6f56c /CMakeLists.txt
parentc1ff5cfa99f0524a7c0a1d5dc4cad0e7cce5f567 (diff)
downloadopenlmi-providers-5e4d1ea25b66830c428f00f6a9db3b650dcd1696.tar.gz
openlmi-providers-5e4d1ea25b66830c428f00f6a9db3b650dcd1696.tar.xz
openlmi-providers-5e4d1ea25b66830c428f00f6a9db3b650dcd1696.zip
Add version to mof/reg registration
Both (un)register-$PROVIDER and specfile are updated to use version during register/unregister. Version of OpenLMI-Providers *MUST* be kept up-to-date in top level CMakeLists.txt.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 834ffa5..ed4fd27 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,11 @@
project(openlmi-providers C)
+set(OPENLMI_VERSION_MAJOR 0)
+set(OPENLMI_VERSION_MINOR 0)
+set(OPENLMI_VERSION_REVISION 25)
+set(OPENLMI_VERSION "${OPENLMI_VERSION_MAJOR}.${OPENLMI_VERSION_MINOR}.${OPENLMI_VERSION_REVISION}")
+
cmake_minimum_required(VERSION 2.6)
# Set flags and definitions