summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRadek Novacek <rnovacek@redhat.com>2012-07-23 12:56:49 +0200
committerRadek Novacek <rnovacek@redhat.com>2012-07-23 12:56:49 +0200
commitfcb9f58e9ad3a2df5b9e003441f341805cebc051 (patch)
tree5737668157aaf8d379700389302f192ebbfa54ad /CMakeLists.txt
parent7bc4421f26954c2acd817c690cbbde03a4391878 (diff)
downloadopenlmi-providers-fcb9f58e9ad3a2df5b9e003441f341805cebc051.tar.gz
openlmi-providers-fcb9f58e9ad3a2df5b9e003441f341805cebc051.tar.xz
openlmi-providers-fcb9f58e9ad3a2df5b9e003441f341805cebc051.zip
Start converting all providers to CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..29cb9bd
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,22 @@
+
+cmake_minimum_required(VERSION 2.6)
+
+# Set flags and definitions
+add_definitions(-D_XOPEN_SOURCE=500 -D_GNU_SOURCE)
+set(CMAKE_C_FLAGS "-std=c99 -Wall -pedantic -g -Wextra -Wno-unused-parameter -Wformat -Wparentheses -Wmaybe-uninitialized")
+
+# Set LIB_SUFFIX to 64 on 64bit architectures
+if(CMAKE_SIZEOF_VOID_P EQUAL 4)
+ set(LIB_SUFFIX "")
+else(CMAKE_SIZEOF_VOID_P EQUAL 4)
+ SET(LIB_SUFFIX 64)
+endif(CMAKE_SIZEOF_VOID_P EQUAL 4)
+
+# Set path to custom cmake modules
+set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules ${CMAKE_MODULE_PATH})
+
+# Find required packages
+find_package(CMPI REQUIRED)
+find_package(KonkretCMPI REQUIRED)
+
+add_subdirectory(src)