summaryrefslogtreecommitdiffstats
path: root/path_utils/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'path_utils/configure.ac')
-rw-r--r--path_utils/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/path_utils/configure.ac b/path_utils/configure.ac
index 87dd615..7978b40 100644
--- a/path_utils/configure.ac
+++ b/path_utils/configure.ac
@@ -9,6 +9,12 @@ AC_PROG_INSTALL
AM_CONDITIONAL([HAVE_GCC], [test "$ac_cv_prog_gcc" = yes])
+PKG_CHECK_MODULES([CHECK], [check >= 0.9.5], [have_check=1], [have_check=])
+if test x$have_check = x; then
+ AC_MSG_WARN([Without the 'CHECK' libraries, you will be unable to run all tests in the 'make check' suite])
+fi
+AM_CONDITIONAL([HAVE_CHECK], [test x$have_check != x])
+
m4_pattern_allow([AM_SILENT_RULES])
AM_SILENT_RULES