summaryrefslogtreecommitdiffstats
path: root/path_utils/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'path_utils/Makefile.am')
-rw-r--r--path_utils/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/path_utils/Makefile.am b/path_utils/Makefile.am
index 45910a9..5cd797b 100644
--- a/path_utils/Makefile.am
+++ b/path_utils/Makefile.am
@@ -7,6 +7,8 @@ endif
ACLOCAL_AMFLAGS = -I m4
+DOXYGEN = @DOXYGEN@
+
pkgconfigdir = $(libdir)/pkgconfig
dist_pkgconfig_DATA = path_utils.pc
@@ -34,3 +36,15 @@ path_utils_ut_LDADD = \
TESTS = $(check_PROGRAMS)
tests: all $(check_PROGRAMS)
+
+if HAVE_DOXYGEN
+docs:
+ rm -fR doc
+ mkdir -p doc
+ $(DOXYGEN) path_utils.cfg.doxy
+else
+docs:
+ @echo "Doxygen not installed, cannot generate documentation"
+ @exit 1
+endif
+