summaryrefslogtreecommitdiffstats
path: root/path_utils/Makefile.am
diff options
context:
space:
mode:
authorJohn Dennis <jdennis@jdennis.(none)>2009-07-14 11:25:37 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-07-15 08:56:51 -0400
commitd54321a3935f8dd62a0cf7281cbdaf96e7c6e294 (patch)
tree42ec0d93df08b6190213147bf2b78128812dd1d8 /path_utils/Makefile.am
parente02d262cd539c3520222ad4e276daacaa7be6d46 (diff)
downloadding-libs-d54321a3935f8dd62a0cf7281cbdaf96e7c6e294.tar.gz
ding-libs-d54321a3935f8dd62a0cf7281cbdaf96e7c6e294.tar.xz
ding-libs-d54321a3935f8dd62a0cf7281cbdaf96e7c6e294.zip
add path_utils filesystem path manipulation utility functions
remove trace macro, not needed modifications to satisfy Stephen's checkin review correct spelling of PATH_UTILS_ERROR_NOT_FULLY_NORMALIZED add checks for truncation, return error add checks for getcwd errors modify (dst >= dst_end) test to be (dst > dst_end) remove all use of tabs remove all trailing whitespace add missing truncation check after strncpy() Fix path_utils.pc Also correct a minor typo.
Diffstat (limited to 'path_utils/Makefile.am')
-rw-r--r--path_utils/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/path_utils/Makefile.am b/path_utils/Makefile.am
new file mode 100644
index 0000000..fdda791
--- /dev/null
+++ b/path_utils/Makefile.am
@@ -0,0 +1,17 @@
+AM_CFLAGS =
+if HAVE_GCC
+ AM_CFLAGS += \
+ -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
+ -Wcast-align -Wwrite-strings
+endif
+
+ACLOCAL_AMFLAGS = -I m4
+
+pkgconfigdir = $(libdir)/pkgconfig
+dist_noinst_DATA = path_utils.pc
+
+noinst_LTLIBRARIES = libpath_utils.la
+libpath_utils_la_SOURCES = \
+ path_utils.c \
+ path_utils.h
+