summaryrefslogtreecommitdiffstats
path: root/path_utils/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2010-03-19 13:59:02 +0100
committerStephen Gallagher <sgallagh@redhat.com>2010-03-25 12:14:14 -0400
commit7ea74ac64811265384c8b2b2a6f12f88b63b3d95 (patch)
tree8d67d6f54d6f66c616bb81182a53525156f8470d /path_utils/Makefile.am
parent404f1fff24862a2b754354b268a0ae74de12d71f (diff)
downloadding-libs-7ea74ac64811265384c8b2b2a6f12f88b63b3d95.tar.gz
ding-libs-7ea74ac64811265384c8b2b2a6f12f88b63b3d95.tar.xz
ding-libs-7ea74ac64811265384c8b2b2a6f12f88b63b3d95.zip
Generate doxygen documentation for path_utils
Diffstat (limited to 'path_utils/Makefile.am')
-rw-r--r--path_utils/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/path_utils/Makefile.am b/path_utils/Makefile.am
index 45910a9..5cd797b 100644
--- a/path_utils/Makefile.am
+++ b/path_utils/Makefile.am
@@ -7,6 +7,8 @@ endif
ACLOCAL_AMFLAGS = -I m4
+DOXYGEN = @DOXYGEN@
+
pkgconfigdir = $(libdir)/pkgconfig
dist_pkgconfig_DATA = path_utils.pc
@@ -34,3 +36,15 @@ path_utils_ut_LDADD = \
TESTS = $(check_PROGRAMS)
tests: all $(check_PROGRAMS)
+
+if HAVE_DOXYGEN
+docs:
+ rm -fR doc
+ mkdir -p doc
+ $(DOXYGEN) path_utils.cfg.doxy
+else
+docs:
+ @echo "Doxygen not installed, cannot generate documentation"
+ @exit 1
+endif
+