summaryrefslogtreecommitdiffstats
path: root/ini/configure.ac
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2009-12-07 09:24:32 -0500
committerStephen Gallagher <sgallagh@redhat.com>2009-12-10 17:20:26 -0500
commit150431bbb08bfac7ec0bd751a405b91f79646640 (patch)
tree05a5b4d09bf9c99e0278ff90cd9a81998c021c7b /ini/configure.ac
parentf1e963ecdfde201e80251462e4e7737a0ef00eae (diff)
downloadding-libs-150431bbb08bfac7ec0bd751a405b91f79646640.tar.gz
ding-libs-150431bbb08bfac7ec0bd751a405b91f79646640.tar.xz
ding-libs-150431bbb08bfac7ec0bd751a405b91f79646640.zip
INI: Cleaning FIXME comments.
Added configurable key length. Changed comments for the functions that are currently not used and reserved for future functionality.
Diffstat (limited to 'ini/configure.ac')
-rw-r--r--ini/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/ini/configure.ac b/ini/configure.ac
index c599124..ef8f0de 100644
--- a/ini/configure.ac
+++ b/ini/configure.ac
@@ -21,5 +21,7 @@ AC_ARG_ENABLE([trace],
[trace_level="0"])
AS_IF([test ["$trace_level" -gt "0"] -a ["$trace_level" -lt "8"] ],[AC_SUBST([TRACE_VAR],["-DTRACE_LEVEL=$trace_level"])])
+AC_DEFINE([MAX_KEY], [1024], [Max length of the key in the INI file.])
+
AC_CONFIG_FILES([Makefile ini_config.pc])
AC_OUTPUT