summaryrefslogtreecommitdiffstats
path: root/collection/Makefile.am
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2010-03-05 17:23:00 -0500
committerStephen Gallagher <sgallagh@redhat.com>2010-03-08 13:42:47 -0500
commitf50374ed1a3d40a984f2386c05306a7ecdd21e95 (patch)
tree011426d78472eb224cb0b09def40b1ba6066a88f /collection/Makefile.am
parentf003197d370bd177027bd7042206892c7ada5771 (diff)
downloadding-libs-f50374ed1a3d40a984f2386c05306a7ecdd21e95.tar.gz
ding-libs-f50374ed1a3d40a984f2386c05306a7ecdd21e95.tar.xz
ding-libs-f50374ed1a3d40a984f2386c05306a7ecdd21e95.zip
Documentation for collection interface
Passed through the interface and changed the comments to comply with the collection interface.
Diffstat (limited to 'collection/Makefile.am')
-rw-r--r--collection/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/collection/Makefile.am b/collection/Makefile.am
index 36e9558..b9975d1 100644
--- a/collection/Makefile.am
+++ b/collection/Makefile.am
@@ -1,6 +1,8 @@
#DEBUG_FLAGS=@DEBUG_VAR@
TRACE_LEVEL=@TRACE_VAR@
+DOXYGEN = @DOXYGEN@
+
topdir=$(srcdir)/..
AM_CFLAGS =
@@ -50,6 +52,22 @@ collection_stack_ut_LDADD = libcollection.la
collection_queue_ut_SOURCES = collection_queue_ut.c
collection_queue_ut_LDADD = libcollection.la
+if HAVE_DOXYGEN
+docs:
+# A temp way of building docs until we hook into the package build
+ rm -fR doc
+ mkdir -p doc
+ $(DOXYGEN) collection.cfg.doxy
+else
+docs:
+ @echo "Doxygen not installed, cannot generate documentation"
+ @exit 1
+endif
+
+
TESTS = collection_ut collection_stack_ut collection_queue_ut
tests: all $(check_PROGRAMS)
+
+clean-local:
+ rm -Rf doc