summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Dennis <jdennis@jdennis.(none)>2009-07-14 11:25:37 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-07-15 08:56:51 -0400
commitd54321a3935f8dd62a0cf7281cbdaf96e7c6e294 (patch)
tree42ec0d93df08b6190213147bf2b78128812dd1d8 /Makefile.am
parente02d262cd539c3520222ad4e276daacaa7be6d46 (diff)
downloadding-libs-d54321a3935f8dd62a0cf7281cbdaf96e7c6e294.tar.gz
ding-libs-d54321a3935f8dd62a0cf7281cbdaf96e7c6e294.tar.xz
ding-libs-d54321a3935f8dd62a0cf7281cbdaf96e7c6e294.zip
add path_utils filesystem path manipulation utility functions
remove trace macro, not needed modifications to satisfy Stephen's checkin review correct spelling of PATH_UTILS_ERROR_NOT_FULLY_NORMALIZED add checks for truncation, return error add checks for getcwd errors modify (dst >= dst_end) test to be (dst > dst_end) remove all use of tabs remove all trailing whitespace add missing truncation check after strncpy() Fix path_utils.pc Also correct a minor typo.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 42bd483..d3329c9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = trace collection ini dhash
+SUBDIRS = trace collection ini dhash path_utils
if SINGLELIB
# Build all components as a single shared library
lib_LTLIBRARIES = libsssd_util.la