summaryrefslogtreecommitdiffstats
path: root/manuals_and_examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'manuals_and_examples/Makefile.am')
-rw-r--r--manuals_and_examples/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/manuals_and_examples/Makefile.am b/manuals_and_examples/Makefile.am
index c8c48ea..9d50775 100644
--- a/manuals_and_examples/Makefile.am
+++ b/manuals_and_examples/Makefile.am
@@ -30,8 +30,11 @@ dest_Makefile=$(DESTDIR)$(pkgdatadir)/examples/c++/Makefile
install-data-hook:
-# Set the rasdaman installation root to allow Make finding
-# include/ and lib/ for the C++ examples.
- sed 's|~~~rmanhome~~~|$(prefix)|' <$(dest_Makefile) >$(dest_Makefile).new
- mv $(dest_Makefile).new $(dest_Makefile)
+ $(SED) \
+ -e 's|[@]pkgincludedir@|$(pkgincludedir)|g' \
+ -e 's|[@]pkglibdir@|$(pkglibdir)|g' \
+ < $(dest_Makefile) > $(dest_Makefile).new
+ mv -f $(dest_Makefile).new $(dest_Makefile)
-# install documentation
(cd ..; doxygen manuals_and_examples/doxygen-all.cfg)
(cd ..; doxygen manuals_and_examples/doxygen-api.cfg)