summaryrefslogtreecommitdiffstats
path: root/clientcomm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'clientcomm/Makefile.am')
-rw-r--r--clientcomm/Makefile.am64
1 files changed, 64 insertions, 0 deletions
diff --git a/clientcomm/Makefile.am b/clientcomm/Makefile.am
new file mode 100644
index 0000000..62f6b7c
--- /dev/null
+++ b/clientcomm/Makefile.am
@@ -0,0 +1,64 @@
+# -*-Makefile-*- (for Emacs)
+#
+# This file is part of rasdaman community.
+#
+# Rasdaman community is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# Rasdaman community is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with rasdaman community. If not, see <http://www.gnu.org/licenses/>.
+#
+# Copyright 2003, 2004, 2005, 2006, 2007, 2008, 2009 Peter Baumann /
+# rasdaman GmbH.
+#
+# For more information please see <http://www.rasdaman.org>
+# or contact Peter Baumann via <baumann@rasdaman.com>.
+#
+# MAKEFILE FOR:
+# module clientcomm
+#
+# COMMENTS:
+# - build of akgnet should be revisited wrt. 3rdParty!
+#
+##################################################################
+
+AM_CXXFLAGS = @CLIENTCXXFLAGS@
+AM_LDFLAGS = @CLIENTLDFLAGS@
+
+noinst_LIBRARIES=libclientcomm.a
+libclientcomm_a_SOURCES = rpcif_clnt.cc rpcif_xdr.c rpcif.h \
+ clientcomm.cc clientcomm.hh rpcclientcomm.cc \
+ rpcclientcomm.hh clientcomm.icc \
+ ../mymalloc/mymalloc_cln.cc ../mymalloc/mymalloc.h
+EXTRA_libclientcomm_a_SOURCES = rpcif.x
+BUILT_SOURCES= rpcif_clnt.cc rpcif_xdr.c rpcif.h rpcif_svc.cc
+CLEANFILES=rpcif_clnt.cc rpcif_xdr.c rpcif.h rpcif.h.tmp rpcif_clnt.c.tmp \
+ rpcif_svc.cc.tmp rpcif_svc.cc
+
+
+rpcif.h: rpcif.x
+ $(RPCGEN) -h -o rpcif.h.tmp rpcif.x
+ $(AWK) -f rpcif.h.awk rpcif.h.tmp > rpcif.h
+ rm rpcif.h.tmp
+
+rpcif_clnt.cc: rpcif.x
+ $(RPCGEN) -l -o rpcif_clnt.cc.tmp rpcif.x
+ $(AWK) -f rpcif_clnt.c.awk rpcif_clnt.cc.tmp > rpcif_clnt.cc
+ rm rpcif_clnt.cc.tmp
+
+rpcif_xdr.c: rpcif.x
+ -rm rpcif_xdr.c
+ $(RPCGEN) -c -o rpcif_xdr.c rpcif.x
+
+rpcif_svc.cc: rpcif.x
+ $(RPCGEN) -m -o rpcif_svc.cc.tmp rpcif.x
+ $(AWK) -f rpcif_svc.c.awk rpcif_svc.cc.tmp > rpcif_svc.cc
+ rm rpcif_svc.cc.tmp
+