summaryrefslogtreecommitdiffstats
path: root/clientcomm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'clientcomm/Makefile.am')
-rw-r--r--clientcomm/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/clientcomm/Makefile.am b/clientcomm/Makefile.am
index 3e1c03b..c2e6f43 100644
--- a/clientcomm/Makefile.am
+++ b/clientcomm/Makefile.am
@@ -29,9 +29,9 @@
#
##################################################################
-pkglib_LIBRARIES=libclientcomm.a
-nodist_libclientcomm_a_SOURCES = rpcif_clnt.cc rpcif_xdr.c rpcif.h
-libclientcomm_a_SOURCES = clientcomm.cc clientcomm.hh rpcclientcomm.cc \
+pkglib_LTLIBRARIES = libclientcomm.la
+nodist_libclientcomm_la_SOURCES = rpcif_clnt.cc rpcif_xdr.c rpcif.h
+libclientcomm_la_SOURCES = clientcomm.cc clientcomm.hh rpcclientcomm.cc \
rpcclientcomm.hh clientcomm.icc \
../mymalloc/mymalloc_cln.cc ../mymalloc/mymalloc.h \
../rnprotocol/rnprotocol.cc \
@@ -44,11 +44,11 @@ libclientcomm_a_SOURCES = clientcomm.cc clientcomm.hh rpcclientcomm.cc \
../rnprotocol/rnpclientcomm.cc \
../rnprotocol/rnpclientcomm2.cc \
../rnprotocol/rnpclientcomm.hh
-libclientcomm_a_CPPFLAGS = $(AM_CPPFLAGS)
-libclientcomm_a_CPPFLAGS += -I$(top_srcdir)/rnprotocol
-libclientcomm_a_CPPFLAGS += $(CLIENT_CPPFLAGS)
+libclientcomm_la_CPPFLAGS = $(AM_CPPFLAGS)
+libclientcomm_la_CPPFLAGS += -I$(top_srcdir)/rnprotocol
+libclientcomm_la_CPPFLAGS += $(CLIENT_CPPFLAGS)
-EXTRA_libclientcomm_a_SOURCES = rpcif.x
+EXTRA_libclientcomm_la_SOURCES = rpcif.x
BUILT_SOURCES =
CLEANFILES =