summaryrefslogtreecommitdiffstats
path: root/bin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bin/Makefile.am')
-rw-r--r--bin/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/bin/Makefile.am b/bin/Makefile.am
new file mode 100644
index 0000000..a9ad8a0
--- /dev/null
+++ b/bin/Makefile.am
@@ -0,0 +1,47 @@
+#
+# This file is part of rasdaman community.
+#
+# Rasdaman community is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# Rasdaman community is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with rasdaman community. If not, see <http://www.gnu.org/licenses/>.
+#
+# Copyright 2003, 2004, 2005, 2006, 2007, 2008, 2009 Peter Baumann /
+# rasdaman GmbH.
+#
+# For more information please see <http://www.rasdaman.org>
+# or contact Peter Baumann via <baumann@rasdaman.com>.
+#
+###################################################################
+
+bin_SCRIPTS = start_rasdaman.sh stop_rasdaman.sh create_db.sh rasmgr.conf
+EXTRA_DIST = stop_rasdaman.sh.in start_rasdaman.sh.in create_db.sh.in rasmgr.conf.in
+CLEANFILES = start_rasdaman.sh stop_rasdaman.sh create_db.sh rasmgr.conf
+dist_sysconf_DATA=rasmgr.conf
+dist_pkgdata_DATA=errtxts_en errtxts_de errtxts_fr errtxts
+
+script_edit = $(SED) \
+ -e 's|@logdir[@]|$(logdir)/|g' \
+ -e 's|@bindir[@]|$(bindir)/|g' \
+ -e 's|@pkgdatadir[@]|$(pkgdatadir)/|g'
+
+start_rasdaman.sh stop_rasdaman.sh create_db.sh: Makefile
+ rm -f $@
+ $(script_edit) '$@.in' >$@
+ chmod +x $@
+ chmod a-w $@
+
+start_rasdaman.sh: start_rasdaman.sh.in
+stop_rasdaman.sh: stop_rasdaman.sh.in
+create_db.sh: create_db.sh.in
+rasmgr.conf: rasmgr.conf.in Makefile
+ rm -f $@
+ $(SED) -e "s|@hostname[@]|`hostname`|g" '$@.in' >$@