summaryrefslogtreecommitdiffstats
path: root/bin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bin/Makefile.am')
-rw-r--r--bin/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/bin/Makefile.am b/bin/Makefile.am
index 72a45fe..348a4b2 100644
--- a/bin/Makefile.am
+++ b/bin/Makefile.am
@@ -35,7 +35,7 @@ script_edit = $(SED) \
start_rasdaman.sh stop_rasdaman.sh create_db.sh: Makefile
rm -f $@
- $(script_edit) '$@.in' >$@
+ $(script_edit) "$(srcdir)/$$(basename "$@").in" >$@
chmod +x $@
chmod a-w $@
@@ -44,4 +44,4 @@ stop_rasdaman.sh: stop_rasdaman.sh.in
create_db.sh: create_db.sh.in
rasmgr.conf: rasmgr.conf.in Makefile
rm -f $@
- $(SED) -e "s|@hostname[@]|`hostname`|g" '$@.in' >$@
+ $(SED) -e "s|@hostname[@]|`hostname`|g" "$(srcdir)/$$(basename "$@").in" >$@