summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 22 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index e2565ec..c624c8b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,9 +32,28 @@
ACLOCAL_AMFLAGS = -I m4
-nobase_pkginclude_HEADERS=raslib/*.h raslib/*.hh raslib/*.icc raslib/*.cc \
- rasodmg/*.hh rasodmg/*.cc rasodmg/*.icc conversion/*.h conversion/*.hh \
- compression/*.hh clientcomm/*.h clientcomm/*.hh
+nobase_pkginclude_HEADERS =
+include $(srcdir)/header-files.mk
+
+dist-hook:
+ (echo "# DO NOT MODIFY THIS FILE"; \
+ echo "# This file was autogenerated by the dist-hook target"; \
+ cd "$(srcdir)"; \
+ find raslib -type f \
+ \( -name '*.h' -or -name '*.hh' -or -name '*.icc' -or -name '*.cc' \) ; \
+ find rasodmg -type f \
+ \( -name '*.hh' -or -name '*.cc' -or -name '*.icc' \) ; \
+ find conversion -type f \( -name '*.h' -or -name '*.hh' \) ; \
+ find compression -type f -name '*.hh' ; \
+ find clientcomm -type f \( -name '*.h' -or -name '*.hh' \) \
+ ) | $(SED) 's,^\([^#]\),nobase_pkginclude_HEADERS += \1,' \
+ > header-files.mk.new
+ if test -f "$(srcdir)/header-files.mk" \
+ && cmp "header-files.mk.new" "$(srcdir)/header-files.mk"; then \
+ rm -f "header-files.mk.new"; \
+ else \
+ mv -f "header-files.mk.new" "$(srcdir)/header-files.mk"; \
+ fi
SUBDIRS = relblobif relindexif relmddif relcatalogif reladminif relstorageif \
indexmgr catalogmgr tilemgr storagemgr compression commline network \