summaryrefslogtreecommitdiffstats
path: root/insertutils/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2011-03-05 00:40:17 +0100
committerHans Ulrich Niedermann <hun@n-dimensional.de>2011-03-07 20:57:37 +0100
commit8ab6afb0c446c1ad5874b55e0f611627849ff2e8 (patch)
treea2c45765eca629fa11a9fc208d916b2b8bb34151 /insertutils/Makefile.am
parent6d75aed5d100995f93c35d53652d0b95b4a8f95e (diff)
downloadrasdaman-upstream-8ab6afb0c446c1ad5874b55e0f611627849ff2e8.tar.gz
rasdaman-upstream-8ab6afb0c446c1ad5874b55e0f611627849ff2e8.tar.xz
rasdaman-upstream-8ab6afb0c446c1ad5874b55e0f611627849ff2e8.zip
build: Free up CPPFLAGS & Co. for users
The CPPFLAGS, CFLAGS, CXXFLAGS, LDFLAGS vars should be free for use by the person who does the build, so rasdaman itself should put all its internally needed flags to AM_CPPFLAGS, AM_CFLAGS, AM_CXXFLAGS, *_LIBS instead. We do just that, and also put all the C preprocessor defines in _CPPFLAGS so they are used for compiling both C and C++ source files. This redistributes some responsibilities from the _CFLAGS and _CXXFLAGS vars. Also use _LDADD _LIBS where appropriate. As a result, the user can now properly set CPPFLAGS, CFLAGS, CXXFLAGS, LDFLAGS at configure or make time and have these values used in the build.
Diffstat (limited to 'insertutils/Makefile.am')
-rw-r--r--insertutils/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/insertutils/Makefile.am b/insertutils/Makefile.am
index d2bf0c0..4eb646e 100644
--- a/insertutils/Makefile.am
+++ b/insertutils/Makefile.am
@@ -29,8 +29,6 @@
#
##################################################################
-AM_CXXFLAGS = $(COMMCXXFLAGS)
-AM_LDFLAGS = $(COMMLDFLAGS)
bin_PROGRAMS = insertppm
rdmexecbin_SCRIPTS = insertdemo.sh
insertppm_SOURCES=insertppm.cc ../mymalloc/mymalloc_cln.cc
@@ -38,6 +36,11 @@ insertppm_LDADD=../rasodmg/librasodmg.a ../clientcomm/libclientcomm.a \
../compression/libcompression.a ../conversion/libconversion.a \
../raslib/libraslib.a \
../network/libnetwork.a
+
+insertppm_CPPFLAGS = $(AM_CPPFLAGS)
+insertppm_CPPFLAGS += $(COMM_CPPFLAGS)
+insertppm_LDADD += $(COMM_LIBS)
+
CLEANFILES = insertdemo.sh
EXTRA_DIST = insertdemo.sh.in