summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBihemo Kimasa <b.kimasa@jacobs-university.de>2011-02-11 13:04:16 +0100
committerwww-data <www-data@ubuntu.localdomain>2011-02-16 10:00:49 +0100
commit93445fe29563387538a4529d61922d8b814d240f (patch)
tree2683140bb0a80ab5bed5d7665f8925d28856217b /configure.ac
parent5471d638899dbf3f52178f8840d0016b0f76f4b2 (diff)
downloadrasdaman-upstream-93445fe29563387538a4529d61922d8b814d240f.tar.gz
rasdaman-upstream-93445fe29563387538a4529d61922d8b814d240f.tar.xz
rasdaman-upstream-93445fe29563387538a4529d61922d8b814d240f.zip
change --with-hdf to --with-hdf4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 11 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 53aa17e..ec9b557 100644
--- a/configure.ac
+++ b/configure.ac
@@ -140,7 +140,7 @@ AC_CONFIG_FILES([Makefile
####################################################################
AH_TEMPLATE([DEBUG], [Enables debug functionality])
AH_TEMPLATE([RMANDEBUG], [Enables debug functionality])
-AH_TEMPLATE([HAVE_HDF], [Checks whether HDF is installed])
+AH_TEMPLATE([HAVE_HDF], [Checks whether HDF4 is installed])
AH_TEMPLATE([RMANVERSION], [The version of Rasdaman currently compiled])
AH_TEMPLATE([BASEDB_PGSQL], [If defined we are compiling over PostgreSQL])
AH_TEMPLATE([__NO_MATH_INLINES], [Used by some performance implementaion of math libraries.])
@@ -158,17 +158,17 @@ AH_TEMPLATE([CONFDIR], [The directory where the installed programs will find the
# --------------- Parameter Definition -----------------------------
####################################################################
AC_PRESERVE_HELP_ORDER
-AC_ARG_WITH([hdf],
- [AS_HELP_STRING([--with-hdf],
- [this feature enables the inclusion of hdf library during installation.])],
+AC_ARG_WITH([hdf4],
+ [AS_HELP_STRING([--with-hdf4],
+ [this feature enables the inclusion of hdf4 library during installation.])],
[],
- [with_hdf=no])
+ [with_hdf4=no])
-AC_MSG_NOTICE(using hdf library...$with_hdf)
+AC_MSG_NOTICE(using hdf4 library...$with_hdf4)
-if test "$with_hdf" == yes; then
- AC_CHECK_LIB([df], [main], ,[AC_MSG_FAILURE([--with-hdf was given but libdf.a was not found! Please install.])])
- AC_CHECK_LIB([mfhdf], [main], ,[AC_MSG_FAILURE([--with-hdf was given but libmfhdf.a was not found! Please install.])])
+if test "$with_hdf4" == yes; then
+ AC_CHECK_LIB([df], [main], ,[AC_MSG_FAILURE([--with-hdf4 was given but libdf.a was not found! Please install.])])
+ AC_CHECK_LIB([mfhdf], [main], ,[AC_MSG_FAILURE([--with-hdf4 was given but libmfhdf.a was not found! Please install.])])
AC_DEFINE([HAVE_HDF], [1])
fi
@@ -357,8 +357,8 @@ CXXFLAGS="$CXXFLAGS -DLOGDIR=\\\"\$(logdir)/\\\""
AC_OUTPUT
-if test "$with_hdf" == no; then
-AC_MSG_NOTICE(Warning: presence of hdf libraries not checked. To run rasdaman you will need to have them installed!)
+if test "$with_hdf4" == no; then
+AC_MSG_NOTICE(Warning: presence of hdf4 libraries not checked. To run rasdaman you will need to have them installed!)
fi
AC_MSG_NOTICE([Rasdaman successfully configured, installation path is '${prefix}'.])